ImportError: No Module Named bs4 (BeautifulSoup)


I’m working in Python and using Flask. When I run my main Python file on my computer, it works perfectly, but when I activate venv and run the Flask Python file in the terminal, it says that my main Python file has “No Module Named bs4.” Any comments or advice is greatly appreciated.

Asked By: harryt



Activate the virtualenv, and then install BeautifulSoup4:

$ pip install BeautifulSoup4

When you installed bs4 with easy_install, you installed it system-wide. So your system python can import it, but not your virtualenv python.
If you do not need bs4 to be installed in your system python path, uninstall it and keep it in your virtualenv.

For more information about virtualenvs, read this

Answered By: Balthazar Rouberol

Just tagging onto Balthazar’s answer. Running

pip install BeautifulSoup4

did not work for me. Instead use

pip install beautifulsoup4
Answered By: Airswoop1

For python2.x:

sudo pip install BeautifulSoup4

For python3:

sudo apt-get install python3-bs4
Answered By: SparkAndShine

If you use Pycharm, go to preferences - project interpreter - install bs4.

If you try to install BeautifulSoup, it will still show that no module named bs4.

Answered By: Alice

I will advise you to uninstall the bs4 library by using this command:

pip uninstall bs4

and then install it using this command:

sudo apt-get install python3-bs4

I was facing the same problem in my Linux Ubuntu when I used the following command for installing bs4 library:

pip install bs4

Answered By: Shashank Rawat

The easiest is using easy_install.

easy_install bs4 

It will work if pip fails.

Answered By: puma-lima

If you are using Anaconda for package management, following should do:

conda install -c anaconda beautifulsoup4

Answered By: Arnab Biswas
pip3 install BeautifulSoup4

Try this. It works for me. The reason is well explained here..

Answered By: Wimukthi Rajapaksha

Try this:

sudo python3 -m pip install bs4
Answered By: Rayid Ali
pip3.7 install bs4

Try this. It works with python 3.7

Answered By: Franck Hervé

pip install --user BeautifulSoup4

Answered By: Manoj Kumar

A lot of tutorials/references were written for Python 2 and tell you to use pip install somename. If you’re using Python 3 you want to change that to pip3 install somename.

Answered By: Clarius

You might want to try install bs4 with

pip install --ignore-installed BeautifulSoup4

if the methods above didn’t work for you.

Answered By: zx_

Try reinstalling the module
Try installing with beautiful soup with the below command

pip install --ignore-installed BeautifulSoup4

I did what @rayid-ali said, except I’m on a Windows 10 machine so I left out the sudo. That is, I did the following:

python3 -m pip install bs4

and it worked like a pycharm. Worked like a charm anyway.

Answered By: 23r0c001

Addendum to the original query:



It lists that module bs4 already been installed.

_codecs_kr          blinker             json                six
_codecs_tw          brotli              kaitaistruct        smtpd
_collections        bs4                 keyword             smtplib
_collections_abc    builtins            ldap3               sndhdr
_compat_pickle      bz2                 lib2to3             socket

Proper solution is:

pip install --upgrade bs4

Should solve the problem.

Not only that, it will show same error for other modules as well.
So you got to issue the pip command same way as above for those errored module(s).

Answered By: Biddut Mitra

In case you are behind corporate proxy then try using following command

pip install –proxy= BeautifulSoup4

Answered By: Rohit

I have been searching far and wide in the internet.

I’m using Python 3.6 and MacOS. I have uninstalled and installed with pip3 install bs4 but that didn’t work. It seems like python is not able to detect or search the bs4 module.

This is what worked:
python3 -m pip install bs4

The -m option allows you to add a module name.

Answered By: Clark Ngo

This worked for me.

pipenv pip install BeautifulSoup4

Answered By: Er. Sachish

It is so annoying to find the answer has nothing to do with BeautifulSoup. To the linux users, be vary of running the command ‘python’, version 2 exits and you may have forgotten to change the bash file alias of python. And so you might have created the virtual environment using 3 with

python3 -m venv .venv

So, to install things, go with

python3 -m pip install beautifulsoup4


pip install beautifulsoup4

Things get installed in different versions and you scratch your head as to what is going on.

The better method is ("-U" : Upgrade all package(s) to the newest available version.) :

$ python3 -m pip install -U pip && python3 -m pip install -U bs4 

or install from apt (Debian, Ubuntu, Mint, etc.) :

$ sudo apt install python3-bs4
Answered By: amzy-0

One more solution for PyCharm:

Go to File -> Settings -> Python Interpreter, click on plus sign and find beautifulsoup4.

Click install.

Answered By: Roy O'Bannon

I also experienced this problem with Python 3. In my case I was able to solve it by running:

$ pip3 install BeautifulSoup4

Instead of:

$ pip install BeautifulSoup4

You will need to have pip in your PATH environment variable. If you don’t have it then use this link: python -m pip install beautifulsoup4

This worked for me. Hopefully, it works for you too.

Answered By: ann jenny

In my case, the when do

pip install beautifullsoap4

always gets installed to my python3.9 package
where my

python3 --version

gave the output as Python 3.10.6
I fixed the issue of pip3 install by upgrading the pip and pointing correctly to 3.10 instead of 3.9

Then everything worked as expected

Answered By: Bharathan Kumaran

After reading all the answers, what worked for me was adding the --clean option with pyinstaller.


pyinstaller --onefile --console --clean --name Email_Parser

What I tried and did not work:

  1. Deleting and recreating the virtual environment
  2. python -m pyinstaller
  3. Installing pyinstaller in the virtual environment
Answered By: Yaman Jain