Error installing Python Image Library using pip on Mac OS X 10.9


I want to install PIL on Mavericks using pip but get this error.

_imagingft.c:73:10: fatal error: 'freetype/fterrors.h' file not found
#include <freetype/fterrors.h>
1 error generated.
error: command 'cc' failed with exit status 1

My Command Line Tools are installed and up to date and every hint I found didn’t help.
How can I get this to compile?

EDIT: I just checked, freetype is also already installed via homebrew

Asked By: Lukas Spieß



I just solved this using the steps described in this Stackoverflow answer.
Seems this is Xcode’s fault for installing freetype in strange locations.

Answered By: Lukas Spieß

I’ve solved this problem with this symlink:

ln -s /usr/local/Cellar/freetype/2.5.1/include/freetype2 /usr/local/include/freetype

I have freetype already installed via homebrew too.

Answered By: Dmitry Akinin

With macports, the solution that worked for me:

sudo port install freetype
sudo ln -s /opt/local/include/freetype2 /opt/local/include/freetype

And then re-run the PIL build process.

Answered By: Mike Fogel

I’m using Arch Linux and had this issue. In my case had to manually download and unpack the zip file from . I then edited the file _imagingft.c to change the include path from freetype/fterrors.h to fterrors.h as there was no freetype subdirectory of /usr/include/freetype2 where fterrors.h was located. Finally python install worked fine.

Edit: I should mention this was the solution for installing Pillow, not PIL, but Pillow is just a fork of PIL and it may still be applicable to others with this issue.

Answered By: Beau

Instead of symlinking to a specific version of freetype2, do this:

ln -s /usr/local/include/freetype2 /usr/local/include/freetype

This saves you the trouble of recreating the symlink whenever you upgrade freetype2.

Answered By: mcuelenaere

This is caused by a change in the headers of freetype >= 2.1.5. PIL is not using the correct documented way to include the freetype headers, which causes the build to fail now that freetype finally removed the long-deprecated way of including the headers. This problem is documented right at the top of

NOTE: Starting with FreeType 2.1.6, the old header file inclusion scheme is no longer supported. This means that you now get an error if you do something like the following:

#include <freetype/freetype.h>
#include <freetype/ftglyph.h>

Please take this problem upstream to the developers of PIL and advise them to use the documented way of including freetype headers:

#include <ft2build.h>
#include FT_ERRORS_H

Answered By: neverpanic

In my OSx, I found the .h file in /opt/local/include/freetype2 direcoty. So, I type

sudo ln -s /opt/local/include/freetype2/ /usr/local/include/freetype

it works

Maybe the best way is to add /opt/local/include to your clang’s include path.

Answered By: blowyourheart

After many attempts, I solved this problem compiling the PIL without freetype support. To do that, I simply unlinked from my $PATH using brew unlink freetype and then, pip install PIL==1.1.7.

Answered By: diegofleury

Use Pillow where this issue is fixed “for real”:

And where you can report issues and see them addressed in a timely fashion:

Answered By: aclark

If you’re still looking for answers like I was after reading this and other googling, you may be interested to see this:


Pillow >= 2.1.0 no longer supports “import _imaging”. Please use “from PIL.Image import core as _imaging” instead.

from here

By the time you read this, the page will probably have changed, but the text will be still here at least.

Answered By: volvox

osx yosemite, this worked for me:


$ ln -s /opt/local/include/freetype2/ /usr/local/include/freetype2
$ pip install pil==1.1.7 --allow-external pil --allow-unverified pil
Answered By: Ilja
Categories: questions Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.