Aptana Error-pydev: Port not bound (found port -1)?


I just updated my Aptana Studio3. When I open my python file it says that it can not find map, range and filter and some other methods. but when I run my code, it’ll run without any problem. my code completion doesn’t work any more. The error for code completion when I use CTRL+SPACE is

   Port not bound (found port -1). Is there an enabled firewall? 

I don’t know where the problem is ?!! I searched but I couldn’t find a proper solution. I’m using windows 7.

Asked By: Hadi



but have you checked the windows firewall? as it tells the IDE? You should try to put an exception for Aptana and it should work .. in fact it seems that the method of python builtin does not read directly from python but from a db, most likely via a socket on a port closed by the firewall ..

Answered By: archetipo

I did trace the differrence between Aptana 3.4 and 3.5, found a forked process to start pycompletionserver at specific ports:

/usr/bin/python2.7 -u
48914 48082

In 3.5, this process is not found at all, the version of pydev also changed.

I managed to start the completion server with the same old ports, still Port not bound error occur.

/usr/bin/python2.7 -u
48914 48082 & [1] 6752

khaled:~/Downloads$ pycompletionserver will start pycompletionserver
creating socket pycompletionserver waiting for connection on

Perhaps Aptana has changed the port numbers….

I’m sorry to revert back to 3.4 🙁

Answered By: kholioeg

Performing a clean Aptana reinstall had fixed this for me.

Answered By: Andrej

I had this issue, even with Windows Firewall disabled. I even tried a clean reinstall (version 3.6) to no avail. In the end I was forced to downgrade to Version 3.4.1. It’s now no longer an issue.

Answered By: munkey

It seems that this is solved on PyDev and the problem is you can’t upgrade PyDev on Aptana 3.6.0. Version 3.6.1 takes out the integration with PyDev and lets you upgrade PyDev.
So I installed Aptana 3.6.1 through Beta repository and then installed the latest PyDev.

Aptana Beta link to add to “Available Software Sites” on Aptana:

Upgrade to Aptana 3.6.1. This will uninstall PyDev.

PyDev link to add to “Available Software Sites” on Aptana:

Install PyDev.

And then, “Port not bound” will be solved.

Answered By: daigorocub

I’ve had the same issue for some time now. I originally downgraded to the previous release but have now decided to upgrade to the 3.6.1 beta release and this problem seems to be fixed. Instructions on how to upgrade to 3.6.1 here.

The PyDev interpreter may not get automatically installed when you upgrade so you’ll have to manually install it again. If needed, there are instructions here.

Answered By: idubs11

I know that the OP asked for help in regards with a Windows OS, however if anyone wants to get this working on OS X 10.9+, then follow the steps originally suggested by daigorocub , which are:

  • Aptana Beta link to add to “Available Software Sites” on Aptana
  • Upgrade to Aptana 3.6.1. This will uninstall PyDev.
  • PyDev link to add to “Available Software Sites” on Aptana
  • Install PyDev.

BUT, when installing PyDev uncheck “Show only the latest versions of available software” check box in Aptana’s Help > Install New Software window and make sure that you choose the latest 2.x.x version of PyDev.

PyDev 3.x+ needs Java JDK 7+ in order to run, however for the latest versions of OS X any Java JDK 7+ is only available as the 64 bit version. Aptana Studio 3 for OS X seems to be available in 32 bit only, which requires a 32 bit JDK.

Another option is to install a 64 bit Eclipse IDE and install Aptana Studio 3.6.1 as a plugin and the latest PyDev separately.

Note: You will most probably need to download and install the newest version of Java for OS X 2014-001 from Apple. http://support.apple.com/kb/DL1572?viewlocale=en_US&locale=en_US
This was originally suggested by ChancePance in his answer to “OSX Yosemite – JVM Shared library does not contain the JNI_CreateJavaVM symbol” thread

Answered By: jayBana

I’m running Windows 10, I fixed this issue by running the installer again and picked “repair”. Fixed this issue for me and did not lose any configuration in the process.

Answered By: Markov

Using info from idubs11, I was able to get my Aptana 3.6.1(downloaded 2016-03-01) working. It exhibited the same problem, port not bound. I was not able to uninstall pydev, until…

  1. I added http://pydev.org/updates to the installation sites
  2. I added http://preview.appcelerator.com/aptana/studio3/standalone/update/beta/ to the installation sites
  3. Then clicked Help -> Check for updates
  4. Installed the update.

Now it was in a weird state, no Pydev anymore and now using the beta version. I then used the pydev.org install site to install pydev and now everything works just fine.

Answered By: hunterofcow

After some wasted hours, I just installed liclipse and the problem is solved.

Answered By: anvd
Categories: questions Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.