Change file type in PyCharm


I created a text file, and renamed it into

enter image description here

The problem is that PyCharm does not detect it as a python source so that I can’t execute it.

How can I teach PyCharm that this is python script?
I tried remove the file and recreated it, and created another python file and renamed it; all ends up being the file as text file not Python script.

The version is 3.0.2.

enter image description here


Refactoring does not working.

enter image description here
enter image description here
enter image description here

The file property comes back to text (the original file property that I created before the first refactoring) even after I renamed it as python script.

The weird thing is that no matter where I create the, PyCharm creates it as a text file as if it remembers the name of the file should be text file. I can create python script anything but the

Asked By: prosseek



I cannot say for sure what mistake you’ve made, however, this is the way to properly rename a file:

enter image description here
enter image description here
enter image description here

If the above fails for whatever reason, try the following, otherwise this is bug that you need to report:

enter image description here

Answered By: Games Brainiac

Settings (Preferences on Mac) | Editor | File Types | Text

Check patterns there (bottom list) — you must have had testTreeGen or similar pattern. Just remove it.

UPDATE 2021-02-28:

Since 2020.3 version you should also check under Auto-detect file type by content file type.

See a bit more / with screenshots in this answer: WebStorm File association system does not recognize a file

This usually happens when creating new file and instead of using specific file template you use New | File and forgetting to enter file extension (which is required here as opposed to specific file template which adds file extension automatically) — this is to allow to create ANY file with any extension (e.g. .htaccess or just README).

Since such file (testTreeGen in your case) does not have extension, IDE does not know how to treat it and treats it as plain text (not automatically though — it asking you to choose correct file type with "text file" type preselected, but vast majority of users just hitting enter instead of reading what that screen says — "relax, I’m a professional and I know what I’m doing").

Now, since the testTreeGen pattern is there and it is bigger/more precise that generic *.rb or *.py, file is treated as Text file regardless of file extension — renaming will not help.

Conclusion / advice — pay a bit more attention to confirmation dialogs.

Answered By: LazyOne

I deleted the the .idea folder, I cleared the cache using the File-> Invalidate Chache menu option, I deleted the __pycache__ folders. I also tried to check out a new version into a new folder as well as copy and pasted the relevant files into a new folder.

None of the solutions worked so it seems that if you declare the file wrongly it is globally registered in all projects as this wrong file type.

I just reinstalled PyCharm deleting all settings. However, if I would have had more custom plugs-ins or settings, I would have started playing with the global pycharm settings rather than the project settings. One option might be deleting the C:User<username>.PyCharm<version> folder which should contain the config, this resetting your PyCharm to factory settings. Obviously do not want to replicate the error now.

My short version: The file type is not saved in the project folder so if you do not find a menu option to change it, go and play with the global settings which are saved in the in the folder mentioned above.

Answered By: Coolkau

Go in the Settings –>Editor –> File Types –> Text –> Registered Patterns (lower list box in the dialog) –> Remove the file name that has been added (Should be the file name you accidentally created as text file) by clicking the “-” right hand side. Apply and you should have this speeding ticket off your record.

enter image description here

  1. Select File Types
  2. Scroll down until you see [text]
  3. select [text]
  4. scroll down to the bottom, you should see your file that Pycharm thinks is text
  5. hit the [-] option to remove the text association and hit OK
  6. When you go back to Project view you should see the file associated with the extension you gave it.
Answered By: Dinesh Khetarpal

I think I had the same problem and you probably have to look in Settings –>Editor –> File Types –> Auto-detect file type by content

This is where it can go wrong

This is where to possibly fix it

Answered By: Tarek
Categories: questions Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.