Error "filename.whl is not a supported wheel on this platform"

Question:

I would like to install scipy-0.15.1-cp33-none-win_amd64.whl that I have saved to the local drive. I am using:

pip 6.0.8 from C:Python27Libsite-packages
python 2.7.9 (default, Dec 10 2014, 12:28:03) [MSC v.1500 64 bit (AMD64)]

When I run:

pip install scipy-0.15.1-cp33-none-win_amd64.whl

I get the following error:

scipy-0.15.1-cp33-none-win_amd64.whl is not a supported wheel on this platform

What is the problem?

Asked By: lskrinjar

||

Answers:

cp33 means CPython 3.3.

You need scipy‑0.15.1‑cp27‑none‑win_amd64.whl instead.

Answered By: ismail

This can also be caused by using an out-of-date pip with a recent wheel file.

I was very confused, because I was installing numpy-1.10.4+mkl-cp27-cp27m-win_amd64.whl (from here), and it is definitely the correct version for my Python installation (Windows 64-bit Python 2.7.11). I got the “not supported wheel on this platform” error.

Upgrading pip with python -m pip install --upgrade pip solved it.

Answered By: aldel

I had the same problem while installing scipy-0.17.0-cp35-none-win_amd64.whl and my Python version was 3.5. It returned the same error message:

scipy-0.17.0-cp35-none-win_amd64.whl is not a supported wheel on this platform.

I realized that amd64 is not about my Windows, but about the Python version. Actually I am using a 32-bit Python on a 64-bit Windows. Installing the following file solved the issue:

scipy-0.17.0-cp35-none-win32.whl
Answered By: 1man

I come across this problem because of a wrong name of my package (scipy-0.17.0-cp27-none-win_amd64 (1)).

After I deleted the ‘(1)’ and changed the package to
scipy-0.17.0-cp27-none-win_amd64, the problem got resolved.

Answered By: 刘远圳

I tried to install scikit-image, but I got the following error when I tried to install the .whl file, even though my installed version of Python was 2.7 32-bit:

scikit_image-0.12.3-cp27-cp27m-win32.whl is not a supported wheel on this platform.

However, I also got this message before the error message:

You are using pip version 7.1.0, however version 8.1.2 is available.
You should consider upgrading via the ‘python -m pip install –upgrade pip’ command.

I then ran the command python -m pip install --upgrade pip and then pip install scikit_image-0.12.3-cp27-cp27m-win32.whl worked fine.

Answered By: Ogglas

If you are totally new to Python, read step by step or go directly to 5th step directly.

Follow the below method to install SciPy 0.18.1 on Windows 64-bit, Python 64-bit.

Be careful with the versions of

  1. Python

  2. Windows

  3. .whl version of NumPy and SciPy files

  4. First install NumPy and then SciPy.

     pip install FileName.whl
    
  5. For NumPy: http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy
    For SciPy: http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy

Be aware of the file name (what I mean is check the "cp" number).
Example: scipy-0.18.1-cp35-cp35m-win_amd64.whl

To check which "cp" number is supported by your pip. Go to point number 2 below.

If you are using .whl file, the following errors are likely to occur.

  1. You are using pip version 7.1.0, however version 8.1.2 is available.

You should consider upgrading via the ‘python -m pip install –upgrade pip’ command

  1. scipy-0.15.1-cp33-none-win_amd64.whl.whl is not supported wheel on this platform

For the above error: start Python (in my case 3.5), and type:

import pip print(pip.pep425tags.get_supported())

Output:

[(‘cp35’, ‘cp35m’, ‘win_amd64’), (‘cp35’, ‘none’, ‘win_amd64’), (‘py3’, ‘none’, ‘win_amd64’), (‘cp35’, ‘none’, ‘any’), (‘cp3’, ‘none’, ‘any’), (‘py35’, ‘none’, ‘any’), (‘py3’, ‘none’, ‘any’), (‘py34’, ‘none’, ‘any’), (‘py33’, ‘none’, ‘any’), (‘py32’, ‘none’, ‘any’), (‘py31’, ‘none’, ‘any’), (‘py30’, ‘none’, ‘any’)]

In the output you will observe "cp35" is there, so download "cp35" for NumPy as well as SciPy.

Answered By: Arun Naudiyal

First of all, cp33 means that it is to be used when you have Python 3.3 running on your system. So if you have Python 2.7 on your system, try installing the cp27 version.

Installing scipy-0.18.1-cp27-cp27m-win_amd64.whl, needs a Python 2.7 running and a 64-bit system.

If you are still getting an error saying “scipy-0.18.1-cp27-cp27m-win_amd64.whl is not a supported wheel on this platform”, then go for the win32 version.
By this I mean install scipy-0.18.1-cp27-cp27m-win32.whl instead of the first one.
This is because you might be running a 32-bit python on a 64-bit system.
The last step successfully installed scipy for me.

Answered By: u_found_me

Change the filename to scipy-0.15.1-cp33-none-any.whl and then run this command:

pip install scipy-0.15.1-cp33-none-any.whl

It should work 🙂

Answered By: ravi

I had a similar problem, installing a 64-bit version for Python 2.7 on Windows 7 64-bit. Everything was up-to-date, yet I got the message:

scipy-0.18.1-cp27-cp27m-win_amd64.whl is not supported wheel on this platform

Then I downloaded a 32-bit .whl file and it worked.

pip install scipy-0.18.1-cp27-cp27m-win32.whl

I suspect that the problem was probably that I didn’t have an AMD processor, rather an Intel one, and the SciPy 64-bit version says amd64 at the end.

Answered By: Harsh Trivedi

Try Conda for installation. It seems to resolve versions
on the fly:

conda install scikit-learn

Answered By: tom

Things to check:

  1. You are downloading proper version like cp27 (means for Python 2.7) cp36 (means for Python 3.6).

  2. Check of which architecture (32 bit or 64 bit) your Python is (you can do it so by opening Python IDLE and typing).

     import platform
     platform.architecture()
    

    Now download the file of that bit, irrespective of your system architecture.

  3. Check whether you’re using the correct filename (i.e., it should not be appended with (1) which might happen if you download the file twice)

  4. Check if your pip is updated or not. If not, you can use:

    python -m pip install -upgrade pip

Answered By: Krishna

Simply, if you have more than one Python installation on your system, for example, 2.7/3.4/3.5, it’s necessary you check your installation path. 🙂

Answered By: RaHa VelShodeh

I am using Python 2.7 and a Windows 64-bit system. I was getting the same error for lxml-3.8.0-cp27-cp27m-win_amd64.whl while doing pip install lxml-3.8.0-cp27-cp27m-win_amd64.whl.

Run pip install lxml and it auto-detected and successfully installed the Win32 version (though my system is Windows-64 bit)

cd C:Python27
pip install lxml

Collecting lxml
  Downloading lxml-3.8.0-cp27-cp27m-win32.whl (2.9MB)
    100% |################################| 2.9MB 20kB/s
Installing collected packages: lxml
Successfully installed lxml-3.8.0

So, I will go with @1man’s answer.

Answered By: somnathchakrabarti

During TensorFlow configuration I specified Python 3.6. But default, Python on my system is Python 2.7. Thus pip in my case means pip for 2.7. For me

pip3 install /tmp/tensorflow_pkg/NAME.whl

did the trick.

Answered By: Vladimir Vlasov

In my case (Windows 64-bit, Python 2.7, and Cygwin) the issue was with a missing gcc.

Using apt-cyg install gcc-core enabled me to then use pip2 wheel ... to install my wheels automatically.

Answered By: yeliabsalohcin

I’m deploying Flask using Python 3.4 on IIS.

The following steps worked for me:

  1. Upgrade pip
  2. Install the wheel file for NumPy
  3. pip install pandas
Answered By: Steel

It’s better to check the version of Python where you want to install your package.

If the wheel was built for Python 3 and your Python version is Python 2.x you may get this error.

While installing using pip, follow this convention:

python2 -m pip install XXXXXX.whl # If the .whl file is for Python 2
python3 -m pip install XXXXXX.whl # If the .whl file is for Python 3
Answered By: Patel Sunil

Please do notice that all platform requirements *are taken from the name of the .whl file!

So be very careful with renaming of *.whl package. I occasionally renamed my newly compiled TensorFlow package from

tensorflow-1.11.0-cp36-cp36m-linux_x86_64.whl

to

tensorflow-1.11.0-cp36-cp36m-linux_x86_64_gpu.whl

just to remind myself about GPU support and struggled with

tensorflow-1.11.0-cp36-cp36m-linux_x86_64_gpu.whl is not a supported
wheel on this platform.

error for about half an hour.

Answered By: Ivan Talalaev

In my case, it had to do with not having installed the GDAL core previously. For a guide on how to install the GDAL and Basemap libraries go to GISPython

Answered By: Felipe Gutierrez

For me, it worked when I selected the correct bit of my Python version, not the one of my computer version.

Mine is 32 bit, and my computer is 64 bit. That was the problem and the 32 bit version of fixed it.

To be exact, here is the one that I downloaded and worked for me:

mysqlclient-1.3.13-cp37-cp37m-win32.whl

Once again, just make sure to chose your Python version of bits and not your system one.

Answered By: Fouad Boukredine

I tried a bunch of the stuff in previous answers to no avail.

Previously, I upgraded to pip 18.1, but I kept getting the following error when trying (for pyFltk):

>>from fltk import *

ImportError: DLL load failed %1 is not a valid Win32 Application

I was getting all sorts of errors about the *.whl file not being supported by my machine or something about being unable to remove the correct files from distutils.

I went back to my notes and they indicated that the whl file:

pyFltk-1.3.3.1-cp36-cp36m-win_amd64.whl but I kept getting the error above sooo…

it required pip 9.0.3 to install.

I downgraded my version of pip to 9.0.3:

pip install pip=9.0.3

And the .whl file installed properly.

This is also related to: here

Answered By: Brian S. Penn

I was trying to verify the installation of TensorFlow as specified here on a newly created virtual environment on Python 3.6. On running:

pip3 install --ignore-installed --upgrade "/Users/Salman/Downloads/tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl"

I get the error and/or warning:

tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl is not a supported wheel on this platform.

Since I had previously upgraded from pip to pip3, I simply replaced pip with pip3 as in:

pip3 install --ignore-installed --upgrade "/Users/Salman/Downloads/tensorflow-1.12.0-cp37-cp37m-macosx_10_13_x86_64.whl"

and it worked like a charm!

Answered By: Salman Shokha

I had the same problem

I downloaded the latest pip from https://pypi.org/project/pip/#files

And then….

pip install << downloaded file location >>

And then the Pygame and Kivy installation worked…

Answered By: Vinay Davda

For my case, with a dlib installation into my Python installation (Python 3.6.9), I have found that changing the WHL file name from dlib-19.8.1-cp36-cp36m-win_amd64.whl to dlib-19.8.1-cp36-none-any.whl works for me.

Here is the way I run pip install to install dlib:

pip3 install dlib-19.8.1-cp36-none-any.whl

However, I still wonder whether there are any alternatives to installation of a WHL file by the pip command without changing the name.

Answered By: Wisarut Bholsithi

All right, the problem is easy. TensorFlow requires Python 3.4 – 3.7 and 64 bit. I see then you’re using Python 2.7.

Read the TensorFlow install instructions on Install TensorFlow with pip.

Answered By: Andres Hernandez

cpXX indicates the Python version.

Whichever Python X.X version you have installed into your system, download that particular cpxx file.

For example, if you have installed Python version 3.7 then
install
packagename-packageversion-cp37-cp37m-osx_10_13_x86_64.whl

Answered By: sameer_nubia

This error might happen because of the difference between armv7 and armv6. If you download the package for armv7 and try to install for armv6, this error occurs.

Answered By: FSA
Categories: questions Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.