Django upgrading to 1.9 error "AppRegistryNotReady: Apps aren't loaded yet."


When upgraded to django 1.9 from 1.8 I got this error. I checked answers for similar questions, but I didn’t think this is an issue with any 3rd party packages or apps.

Traceback (most recent call last):
File "", line 10, in <module> execute_from_command_line(sys.argv)
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/core/management/", line 350, in execute_from_command_line
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/core/management/", line 342, in execute
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/core/management/", line 176, in fetch_command
commands = get_commands()
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/utils/", line 100, in wrapper
result = user_function(*args, **kwds)
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/core/management/", line 71, in get_commands
for app_config in reversed(list(apps.get_app_configs())):
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/apps/", line 137, in get_app_configs
File "/home/kishore/.virtualenvs/andone/local/lib/python2.7/site-packages/django/apps/", line 124, in check_apps_ready
raise AppRegistryNotReady("Apps aren't loaded yet.")
django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.

I’d modified the Installed apps for ‘django.contrib.auth’.

Asked By: Kishore K



Try to add this lines to the top of your settings file:

import django

And if this will not help you try to remove third-party applications from your installed apps list one-by-one.

Answered By: inlanger

I’d a custom function written on one of my models file. It was causing the error. When I moved this function from it worked.

Answered By: Kishore K

Try removing the entire settings.LOGGING dictConfig and restart the server. If that works, rewrite the setting according to the v1.9 documentation.

Answered By: pragmar

For me commenting out



Answered By: algometrix

My problem was:

for django 1.9.7 you should use:

I were upgraded django-cms 3.2 to 3.3, and found it by commenting apps, then uncommenting back.

Correct answer here:

Answered By: Anshik

This error may occur when you are adding an app in INSTALLED_APPS in the file but you do not have that app installed in your computer. You have two solution:

  1. Install that app using package managers like pip in ubuntu
  2. Or Comment out that installed app in the file

This error may also arise if you are not in your virtual environment which you may have created for your project.

Answered By: Amrit

This issue is also observed for inconsistent for incorrectly writing INSTALLED_APPS, verify if you correctly included apps and separated with “,” .

Answered By: Waykos

If your files fill are correct´╝îyou can try to arrive files proceed call danjgo.setup() in main method . Then run ,finally again run project ,the issue could disappear.

Answered By: xing liu

In the “admin” module of your app package, do register all the databases created in “models” module of the package.

Suppose you have a database class defined in “models” module as:

class myDb1(models.Model):
    someField= models.Charfiled(max_length=100)

so you must register this in the admin module as:

from .models import myDb1

I hope this resolve the error.

Answered By: Preetam

For me, the problem came from the fact that I was importing an app in INSTALLED_APPS which was itself importing a model in its file

I had :


from django.contrib.sites.models import Site

commenting out import models in made it work :

# from django.contrib.sites.models import Site
Answered By: Albyorix

Late to the party, but grappelli was the reason for my error as well. I looked up the compatible version on pypi and that fixed it for me.

Answered By: lslaz

When I change my django version to 1.9, it don’t arise the error.

pip uninstall django
pip install django==1.9

Answered By: admin

I put the User import into the settings file for managing the rest call token like this

from django.contrib.auth.models import User
def jwt_get_username_from_payload_handler(payload):

    'JWT_PAYLOAD_GET_USERNAME_HANDLER': jwt_get_username_from_payload_handler,
    'JWT_ALGORITHM': 'RS256',

Because at that moment, Django libs are not ready yet. Therefore, I put the import inside the function and it started to work. The function needs to be called after the server is started

Answered By: Thai Tran

My problem was that I tried to import a Django model before calling django.setup()

This worked for me:

import django

from myapp.models import MyModel

The above script is in the project root folder.

Answered By: M3RS

Try activating the virtual env.
In my case, using the git command line tool:

source scripts/activate

Solves my problem.

In my case one of my settings, ‘CORS_ORIGIN_WHITELIST’ was set in the file but was not available in my .env file. So I’ll suggest that you check your settings, especially those linked to .env

Answered By: medobills

In my case, the error occurred when I made python makemigrations on Django 2.0.6.

The solution was to run python runserver and see the actual error (which was just a missing environment variable).

Answered By: Pavel Vergeev

As others have said this can be caused when you’ve not installed an app that is listed in INSTALLED_APPS.

In my case, was attempting to log the exception, which led to an attempt to render it which failed due to the app not being initialized yet. By
commenting out the except clause in the exception was displayed without special rendering, avoiding the confusing error.

# Temporarily commenting out the log statement.
#except Exception as e:
#    log.error('Admin Command Error: %s', ' '.join(sys.argv), exc_info=sys.exc_info())
#    raise e
Answered By: John Lehmann

I tried tons of things, but only downgrading Django to 1.8.18 fixed this issue for me:

pip install django==1.8.18

It is one of the installed apps that is failing, but I could not find which one.

Answered By: oriadam

django.setup() in the top will not work while you are running a script explicitly.
My problem solved when I added this in the bottom of the settings file

BASE_DIR = os.path.dirname(os.path.dirname(os.path.abspath(__file__)))
import sys
if BASE_DIR not in sys.path:
os.environ['DJANGO_SETTINGS_MODULE'] =  "igp_lrpe.settings"
os.environ.setdefault("DJANGO_SETTINGS_MODULE", "igp_lrpe.settings")
import django
Answered By: Arup Barman

Got this error while trying to access model objects in

class QuizConfig(AppConfig):
name = 'quiz'

def ready(self):
    print('===============> Django just started....')
    questions_by_category = Question.objects.filter(category=2) # <=== Guilty line of code.

Trying to access Question before the app has loaded the model class caused the error for me.

I get that error when i try to run:

python makemigrations

i tried so many things and realized that i added some references to “” – “INSTALLED_APPS”

Just be sure what you write there is correct. My mistake was “.model.” instead of “.app.”

Corrected that mistake and it’s working now.

Answered By: Castor

I get that error when I try to run full scripts, I don’t want to use python test)

and the following method is working for me.

import os
import django
if 'env setting':
    os.environ.setdefault('DJANGO_SETTINGS_MODULE', 'YourRoot.settings')
from django.test import TestCase

class SomeTest(TestCase):
    def test_one(self):  # <-- Now, I can run this function by PyCharm

    def test_two(self):
Answered By: Carson

First import and run django.setup() before importing any models

All the above answers are good but there is a simple mistake a person could do is that (In fact in my case it was).

I imported Django model from my app before calling django.setup(). so proper way is to do…

import os
os.environ.setdefault('DJANGO_SETTINGS_MODULE', 'first_project.settings')

import django

then any other import like

from faker import Faker
import random
# import models only after calling django.setup()
from first_app.models import Webpage, Topic, AccessRecord
Answered By: Himanshu Patel

I’ve run into this problem and it was rooted in we’ve loaded the below module:

from channels.auth import AuthMiddlewareStack 

but we didn’t use it in the ProtocolTypeRouter. apparently, we have to use
websocket or other protocols when we call the AuthMiddlewareStack module.

Answered By: Ehsan Ahmadi

For others that might stumble upon this in future:

If you encounter this issue while running Python 3.8 and trying to use multiprocessing package, chances are that it is due to the sub processed are ‘spawned’ instead of ‘forked’. This is a change with Python 3.8 on Mac OS where the default process start method is changed from ‘fork’ to ‘spawn’.
This is a known issue with Django.

To get around it:

import multiprocessing as mp
Answered By: Oscar Chen

You may get this error if you’ve started normal Python shell by mistake and trying to import your Django models in that.

You should instead use python shell for that.

Answered By: Krishna

I think this wasn’t mentioned yet, but is a common cause for the error: The error occurs when you specify startup code that uses models. If you follow this approach and put it into your AppConfig you must not import models at the top of the file, but inside the ready() method. For example as follows:

# works as models are imported in the ready() method
from django.apps import AppConfig

class MatcherConfig(AppConfig):
    name = 'matcher'
    verbose_name = 'Match-Making'
    def ready(self):
        from matcher.background_tasks import close_timeout_games
        from matcher.models import FourPlayerGame
        # check if a player is not responding every 5 seconds
        close_timeout_games(FourPlayerGame, repeat=5)

However, the following would be wrong:

# won't work as models are imported at the beginning
from django.apps import AppConfig
from matcher.background_tasks import close_timeout_games
from matcher.models import FourPlayerGame

class MatcherConfig(AppConfig):
    name = 'matcher'
    verbose_name = 'Match-Making'
    def ready(self):
        # check if a player is not responding every 5 seconds
        close_timeout_games(FourPlayerGame, repeat=5)

For more information also see this answer.

Answered By: F.M.F.

I faced this problem when I was trying to load a function in the init file ( of my settings package.

The cause of this error

django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet

is that, before settings were loaded, I wanted to load another module (e.g. rest_framework).

To solve this, I put functions in another module (file) in settings package
(e.g., and it solved the problem.

I was in trouble with such matter
my problem was because of having this piece of code in

import myapp.models

when I removed this code problem fixed
I recommend check your and remove such code

Answered By: Hamide Kavoosi

The reason I got this error appregistrynotready is That I accidentally Register User model in instead of

This is how it’s looked like

from django.contrib import admin
from django.contrib.auth.admin import UserAdmin as BaseUserAdmin
from .models import User

class UserAdmin(BaseUserAdmin):
Answered By: Azhar Uddin Sheikh

i faced the same issue when i used

from django.urls import reverse


from django.urls import reverse_lazy
Answered By: Sairam Gourishetty
Categories: questions Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.