AWS : The config profile (MyName) could not be found


Every time I want to config something with AWS I get the following error :

"The config profile (myname) could not be found"

like : aws configure

I’m using Python 3.4 and I want to use AWS CLI Keyring to encrypt my credentials..

Asked By: Steve Ritz



can you check your config file under ~/.aws/config– you might have an invalid section called [myname], something like this (this is an example)



Just remove the [myname] section (including all content for this profile) and you will be fine to run aws cli again

Answered By: Frederic Henri

Use as follows


Example cmd

aws --profile myname CMD opts

Did you actually set up your specific user? The walkthrough setup guide in AWS explains how to set a default user, and then how to set up additional users. If you didn’t complete the full setup, you’ll just have a default block and your myName won’t have been created..

Answered By: Mike Pinnell

I think there is something missing from the AWS documentation in, it did not mention that you should edit the file ~/.aws/config to add your username profile. There are two ways to do this:

  1. edit ~/.aws/config or

  2. aws configure --profile "your username"

Answered By: Stanley Yong

Was facing similar issue and found below link more helpful then the answers provided here. I guess this is due to the updates to AWS CLI since the answers are provided.

Essentially it helps to create two different files (i.e. one for the general config related information and the second for the credentials related information).

Answered By: shekharlondhe

I ran into this problem when I moved to a new machine, carrying with me my AWS_DEFAULT_PROFILE environment variable, but not my ~/.aws directory. I couldn’t get any awscli commands to work until I unset that variable or properly configured the named profile. But even the aws configure command was broken, making things a bit tricky. Assuming you have a Unix-like shell handy:

  1. To determine what AWS-specific variables you might have in your session: env | grep AWS_
    • if you don’t see AWS_DEFAULT_PROFILE or AWS_PROFILE listed here, this answer is not applicable to you.
  2. To temporarily remove the default profile: unset AWS_DEFAULT_PROFILE and/or unset AWS_PROFILE
  3. To configure the profile in question: aws --profile foo configure
  4. To reset the default profile variable: exec $SHELL
  5. To test your new setup: aws iam get-user
Answered By: billkw

For me it was because I had my .aws/config file looking like this:

[profile myname]
aws_access_key_id = ....
aws_secret_access_key = ....

I think the reason is I based it off my .aws/credentials file, which requires having [profile myname] for Zappa and maybe some other aws/elastic beanstalk tools.

When I changed config to this it worked great:

aws_access_key_id = ....
aws_secret_access_key = ....
Answered By: owenfi

Make sure you are in the correct VirtualEnvironment. I updated PyCharm and for some reason had to point my project at my VE again. Opening the terminal, I was not in my VE when attempting zappa update (and got this error). Restarting PyCharm, all back to normal.

Answered By: andyw

Working with profiles is little tricky. Documentation can be found at:
(But you need to pay attention on env variables like AWS_PROFILE)

Using profile with aws cli requires a config file (default at ~/.aws/config or set using AWS_CONFIG_FILE).
A sample config file for reference:

[profile PROFILE_NAME]


Env variable AWS_PROFILE informs AWS cli about the profile to use from AWS config. It is not an alternate of config file like AWS_ACCESS_KEY_ID/AWS_SECRET_ACCESS_KEY are for ~/.aws/credentials.

Another interesting fact is if AWS_PROFILE is set and the AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY environment variables are set, then the credentials provided by AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY will override the credentials located in the profile provided by AWS_PROFILE.

Answered By: user6058180

In my case, I had the variable named "AWS_PROFILE" on Environment variables with an old value.

enter image description here

Answered By: Jorge Freitas

In my case, I was using the Docker method for the AWS CLI tool, and I hadn’t read the instructions far enough to realize that I had to make my credentials directory visible to the docker container.

Instead of

docker run --rm -it amazon/aws-cli:latest command args...

I needed to do:

docker run --rm -it -v ~/.aws:/root/.aws amazon/aws-cli:latest command args...

Answered By: BareMetalCoder

Just in case anyone is trying to do this on a headless server (CI runner in my case, adding an EKS cluster config to kubeconfig).

The reason I have to do this is because the runner is in a different AWS account to the EKS cluster in question (and the aws eks command looks in same account).

I do have a way of authenticating to the correct AWS account which populates ~/.aws/credentials with valid creds.

First I authenticate to populate ~/.aws/credentials

cp ~/.aws/credentials ~/.aws/config
sed -i 's/profilename/profile profilename/g' ~/.aws/config

and then when I run following it works

aws eks update-kubeconfig --name cluster-name --profile profilename --region us-east-1
Answered By: kafka

I have faced the same issue while deploying the Flask application in Nginx and Gunicorn.

It may helpful for someone who faces the same issue as I was

My Case: generating rds AUTH Token using AWS credentials

In development mode it is working fine and able to fetch the AWS Config from the .aws folder

when I try to run it via Nginx-Gunicorn Its gets failed, Even though I gave all root permission to respective folders and services.

I have stored AccessKey and SecretKey in environment variables
and creating auth token by using those credentials

import boto3,os
def generate_iam_rds_token(server,region,port,user,S3_KEY,S3_SECRET):
   s3_conn = boto3.client('rds', region_name=region,
   pwd = s3_conn.generate_db_auth_token(server, port, user, Region=region)
   return pwd
#call the method to get a token

SQLALCHEMY_DATABASE_URI = 'postgresql+psycopg2://{user}:{pwd}@{host}:{port}/{db}'.format(user=user,host=host,port=port,db=db,pwd=pwd)

Note: In Ubuntu Os, Login as root user by using sudo -s or respective user that you have configured in gunicorn
Do aws configure

Answered By: Ramesh Ponnusamy

Please note the issue can happen if the aws config file is not found for the user which is starting the service.

For me the issue was the service was starting the root user so it was not able to find the AWS config file. I fixed it by making the service start from non root user sot hat AWS config could be found.

Answered By: Alok Kumar Singh

If you use windows and write a config/credentials by Windows Note app, the app make a file with ".txt" extension. So, you could remove file extension. In my case, it worked.

Answered By: Jack