No module named 'openpyxl' – Python 3.4 – Ubuntu


I installed openpyxl with

$ pip install openpyxl

when I try the command

from openpyxl import Workbook

I get

Traceback (most recent call last):
 File "<pyshell#0>", line 1, in <module>
from openpyxl import Workbook
ImportError: No module named 'openpyxl'

I am using Python 3.4 and Ubuntu 14.04, 32-bit OS type

Asked By: FrancescoVe



@zetysz and @Manish already fixed the problem. I am just putting this in an answer for future reference:

  • pip refers to Python 2 as a default in Ubuntu, this means that pip install x will install the module for Python 2 and not for 3

  • pip3 refers to Python 3, it will install the module for Python 3

Answered By: Caridorc

I had the same problem solved using instead of pip install :

sudo apt-get install python-openpyxl
sudo apt-get install python3-openpyxl

The sudo command also works better for other packages.

Answered By: rainer

In order to keep track of dependency issues, I like to use the conda installer, which simply boils down to:

conda install openpyxl
Answered By: Archie

You have to install it explixitly using the python package manager as

  1. pip install openpyxl for Python 2
  2. pip3 install openpyxl for Python 3
Answered By: utkarshh12

If you don’t use conda, just use :

pip install openpyxl

If you use conda, I’d recommend :

conda install -c anaconda openpyxl

instead of simply conda install openpyxl

Because there are issues right now with conda updating (see GitHub Issue #8842) ; this is being fixed and it should work again after the next release (conda 4.7.6)

Answered By: ToddEmon

If you’re using Python3, then install:

python3 -m pip install --user xlsxwriter

This will run pip with the appropriate version of Python3. If you run bare pip3 and have many versions of Python install, it will still fail leading to more confusion.

The –user flag will allow to install as a regular user and no require root.

Answered By: reisy

I still was not able to import ‘openpyxl’ after successfully installing it via both conda and pip. I discovered that it was installed in ‘/usr/lib/python3/dist-packages’, so this worked for me:

import sys 

Hope this might be useful for others.

Answered By: ConZZito

This work for me in Windows, if you want to export or read from Excel

pip install openpyxl
pip install --user xlsxwriter
pip install xlrd==1.2.0
Answered By: Gustavo Marquez

This is what worked for me:

pip uninstall openpyxl
pip install openpyxl 

Or you can also try

pip3 uninstall openpyxl
pip3 install openpyxl 

If you are using notebooks such as google-colab, jupyter-notebook, etc you can try this:

!pip uninstall openpyxl
!pip install openpyxl 

Or using pip3

!pip3 uninstall openpyxl
!pip3 install openpyxl 

Then you may need to restart your notebook if you are using a notebook.

Answered By: crispengari

What worked with me, including many of the above solutions, is to work in with venv, pip install all the requirements in the new virtual environment and run the program.

Answered By: Yves Laporte

Open PyCharm Package and install OPENPYXL. Its working.

Answered By: Shivam Singh
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.