How to uninstall Anaconda completely from macOS

Question:

How can I completely uninstall Anaconda from MacOS Sierra and revert back to the original Python? I have tried using conda-clean -yes but that doesn’t work. I also remove the stuff in ~/.bash_profile but it still uses the Anaconda python and I can still run the conda command.

Asked By: Jordan Baron

||

Answers:

Open the terminal and remove your entire Anaconda directory, which will have a name such as “anaconda2” or “anaconda3”, by entering the following command: rm -rf ~/anaconda3. Then remove conda with command conda uninstall see https://conda.io/docs/commands/conda-uninstall.html.

Answered By: Monika Bozhinova

To remove the configs:

conda install anaconda-clean
anaconda-clean --yes

Once the configs are removed you can delete the anaconda install folder, which is usually under your home dir:

rm -rf ~/anaconda3

Also, the anaconda-clean --yes command creates a backup in your home directory of the format ~/.anaconda_backup/<timestamp>. Make sure to delete that one also.


EDIT (v5.2.0): Now if you want to clean all, you will also have to delete the two last lines added to your .bash_profile. They look like:

# added by Anaconda3 5.2.0 installer
export PATH="/Users/ody/anaconda3/bin:$PATH"
Answered By: jkysam

To uninstall Anaconda open a terminal window:

  1. Remove the entire anaconda installation directory:
rm -rf ~/anaconda
  1. Edit ~/.bash_profile and remove the anaconda directory from your PATH environment variable.

Note: You may need to edit .bashrc and/or .profile files instead of .bash_profile

  1. Remove the following hidden files and directories, which may have been created in the home directory:

    • .condarc
    • .conda
    • .continuum

Use:

rm -rf ~/.condarc ~/.conda ~/.continuum
Answered By: gogasca

This has worked for me:

conda remove --all --prefix /Users/username/anaconda/bin/python

then also remove from $PATH in .bash_profile

Answered By: evagreen

This is one more place that anaconda had an entry that was breaking my python install after removing Anaconda. Hoping this helps someone else.

If you are using yarn, I found this entry in my .yarn.rc file in ~/”username”

python “/Users/someone/anaconda3/bin/python3”

removing this line fixed one last place needed for complete removal. I am not sure how that entry was added but it helped

Answered By: jstamis

Adding export PATH="/Users/<username>/anaconda/bin:$PATH" (or export PATH="/Users/<username>/anaconda3/bin:$PATH" if you have anaconda 3)
to my ~/.bash_profile file, fixed this issue for me.

Answered By: StOchastiC_

After performing the very helpful suggestions from both spicyramen & jkysam without immediate success, a simple restart of my Mac was needed to make the system recognize the changes. Hope this helps someone!

Answered By: riot

In my case (Mac High Sierra) it was installed at ~/opt/anaconda3.

https://docs.anaconda.com/anaconda/install/uninstall/

Answered By: Laknath

The official instructions seem to be here: https://docs.anaconda.com/anaconda/install/uninstall/

but if you like me that didn’t work for some reason and for some reason your conda was installed somewhere else with telling you do this:

rm -rf ~/opt

I have no idea why it was saved there but that’s what did it for me.


This was useful to me in fixing my conda installation (if that is the reason you are uninstalling it in the first place like me): https://stackoverflow.com/a/60902863/1601580 that ended up fixing it for me. Not sure why conda was acting weird in the first place or installing things wrongly in the first place though…

Answered By: Charlie Parker

The following line doesn’t work?

rm -rf ~/anaconda3 

You should know where your anaconda3(or anaconda1, anaconda2) is installed. So write

which anaconda

output

output: somewhere

Now use that somewhere and run:

rm -rf somewhere 
Answered By: Fatemeh Asgarinejad

MacOS Big Sur and MacOS High Sierra differ: the anaconda folder is ~/opt/anaconda3 instead of ~/anaconda3, according to the comment by jmgonet and answer by Laknath.

Install the cleaner

[email protected]:~$ conda install anaconda-clean

Activate the ‘base’ virtual environment

[email protected]:~$ source ~/anaconda3/bin/activate

Run the cleaner

(base) [email protected]:~$ anaconda-clean --yes

Deactivate the ‘base’ virtual environment

(base) [email protected]:~$ conda deactivate

Remove the files

[email protected]:~$ rm -rf ~/anaconda3
[email protected]:~$ rm -rf ~/.anaconda_backup

Delete lines added by conda from environment file(s)

Open the .bashrc file (and/or .profile and/or .bash_profile)

nano .bashrc

Search for conda:

  1. press CTRL+W
  2. type conda
  3. press ENTER

Remove everything that looks like it has been added by/for anaconda:

# >>> conda initialize >>>
# !! Contents within this block are managed by 'conda init' !!
__conda_setup="$('/home/me/anaconda3/bin/conda' 'shell.bash' 'hook' 2> /dev/null)"
if [ $? -eq 0 ]; then
    eval "$__conda_setup"
else
    if [ -f "/home/me/anaconda3/etc/profile.d/conda.sh" ]; then
        . "/home/me/anaconda3/etc/profile.d/conda.sh"
    else
        export PATH="/home/me/anaconda3/bin:$PATH"
    fi
fi
unset __conda_setup
# <<< conda initialize <<<

This was done on Ubuntu 18.04 and will probably also work on MacOS.

Answered By: Emil Carpenter

None of these solutions worked for me. Turns out I had to remove all the hidden files that you can reveal with ls -a My .zshrc file had some anaconda references in it that needed to be deleted

Answered By: Некто

unset your ~/.bash_profile’s PYTHONPATH and PYTHONHOME

(ps: when you debug Arduino, you may have set those vars. It would confuse the conda’s env)

Answered By: ghostyusheng

After running the uninstall commands for Anaconda, miniconda3 was still showing up in the path. Ultimately this is what worked for me:

With terminal open (I use zsh)

open ~/.zshrc

Delete the contents, save, exit terminal, and reopen.

This solved the eternal conda issue for me, finally!

Answered By: MaryK39