How to solve SyntaxError on autogenerated


I’m following the Django tutorial

I’ve created a "mysite" dummy project (my very first one) and try to test it without altering it.

django-admin startproject mysite
cd mysite
python runserver

File "", line 14
) from exc
SyntaxError: invalid syntax

I’m getting a SyntaxError on a file that was generated by the system itself. And I seem unable to find anyone else who has gone through the same issue.

I’ll add some data of my setup in case it may be of use

$ vpython --version
Python 2.7.12
$ pip --version
pip 9.0.1 from /home/frank/.local/lib/python2.7/site-packages (python 2.7)
$ python -m django --version

Adding contents of autogenerated

#!/usr/bin/env python3
import os
import sys

if __name__ == "__main__":
    os.environ.setdefault("DJANGO_SETTINGS_MODULE", "mysite.settings")
        from import execute_from_command_line
    except ImportError as exc:
        raise ImportError(
            "Couldn't import Django. Are you sure it's installed and "
            "available on your PYTHONPATH environment variable? Did you "
            "forget to activate a virtual environment?"
        ) from exc
Asked By: Frank



After testing with precise instructions (using python2 or python3 instead of just “python”) I’ve constated that no matter what the tutorial says, this works ONLY with python3.

Answered By: Frank

Also, the tutorial recommends that a virtual environment is used (see Django documentation:“). You can do this with pipenv --three. Once you’ve installed django with pipenv install django and activated your virtual environment with pipenv shell, python will refer to python3 when executing python runserver.

Pipenv documentation:

Answered By: d1onysus

Make sure which python version you connect the django with (Make sure to activate the virtual env if you are using any).

When you install django using just

pip install django 

then you have to run

python startapp <yourApp name>

else if you have used:

pip3 install django

then you have to run

python3 startapp <yourapp name>

enter image description here

Answered By: lobsang

Just activate your virtual environment.

Answered By: Esir Kings

Its a simple solution actually one i just ran into. Did you activate your virtual environment?

my terminal screenshot

Answered By: Vipin Mohan

You should activate your virtual environment.
In terminal, source env/bin/activate. Depending on your shell, something like (env) should now be a part of the prompt.

And now runserver should work. No need to delete exc part!

Answered By: Aditya Sinha

You can try with python3 runserver.
It works for me.

Answered By: Fernando

What am I wondering is though the django is installed to the container it may not be in the host machine where you are running the command. Then how will the command run. So since no above solutions worked for me.

I found out the running container and get into the running container using docker exec -it <container> bash then ran the command inside docker container. As we have the volumed container the changes done will also reflect locally. What ever command is to be run can be run inside the running container

Answered By: Tara Prasad Gurung

The django-admin maybe the wrong file.I met the same problem which I did not found on a different computer the same set-up flow.

After comparing two project, I found several difference at and, then I realized I created 2.0 django project but run it with python2.

runwhich django-adminin iterm


It looks like I got a django-admin in python3 which I didn’t know why.So I tried to get the correct django-amin.

pip show django

then I got

Name: Django
Version: 1.11a1
Summary: A high-level Python Web framework that encourages rapid development and clean, pragmatic design.
Author: Django Software Foundation
Author-email: [email protected]
License: BSD
Location: /Library/Python/2.7/site-packages
Requires: pytz

In/Library/Python/2.7/site-packages, I found the django-admin


So I created project again by

/Library/Python/2.7/site-packages/django/bin/ startproject myproject

then run

cd myproject
python runserver


Answered By: chie

For future readers,
I too had the same issue. Turns out installing Python directly from website as well as having another version from Anaconda caused this issue. I had to uninstall Python2.7 and only keep anaconda as the sole distribution.

Answered By: CodeSsscala

Have you entered the virtual environment for django? Run python -m venv myvenv if you have not yet installed.

Answered By: tomilia

We have to create a virtual environment inside the project, not outside the project..
Then it will solve..

Answered By: Shikha Mangal

I was experiencing the same but this was solved by running with specific python 3.6 as below:

python3.6 runserver
Answered By: Martin Karari

You must activate virtual environment where you have installed django.
Then run this command
python runserver

Answered By: Wasique Ansari

Just do:

pipenv shell

Then repeat:

python runserver

And don’t delete from exc as suggested above.

It seems you have more than one version of Python on your computer.
Try and remove one and leave the only version you used to develop your application.

If need be, you can upgrade your version, but ensure you have only one version of Python on your computer.

Answered By: Premium Ayodele

I had same problem and could solve it. It is related to the version of Django you’ve installed, some of them are not supported by python 2.7. If you have installed Django with pip, it means that you are installing the latest version of that which probably is not supported in python 2.7, You can get more information about it here. I would suggest to python 3 or specify the version of Django during installing (which is 1.11 for python 2.7).

Answered By: Keivan

You can just mention your python version, like this,

python3.5 runserver   

It’s best to create a virtual environment and run your Django code inside this virtual environment, this helps in not changing your existing environments. Here are the basic steps to start with the virtual environment and Django.

  1. Create a new Directory and cd into it.

    mkdir test , cd test

  2. Install and Create a Virtual environment.

python3 -m pip install virtualenv virtualenv venv -p python3

  1. Activate Virtual Environment: source venv/bin/activate

  2. Install Django: pip install django

  3. Start a new project: django-admin startproject myproject

  4. cd to your project and Run Project:

cd myproject,

python runserver
  1. You can see your project here:
Answered By: Sbk3824

I solved this problem to uninstall the multiple version of Python.
Check Django Official Documentation for Python compatibility.

"Python compatibility

Django 2.1 supports Python 3.5, 3.6, and 3.7. Django 2.0 is the last version to support Python 3.4." file

#!/usr/bin/env python
import os
import sys

if __name__ == '__main__':
   os.environ.setdefault('DJANGO_SETTINGS_MODULE', 'work.settings')
       from import execute_from_command_line
   except ImportError as exc:
      raise ImportError(
        "Couldn't import Django. Are you sure it's installed and "
        "available on your PYTHONPATH environment variable? Did you "
        "forget to activate a virtual environment?"
      ) from exc

If removing "from exc" from second last line of this code will generate another error due to multiple versions of Python.

activate env by the Following Command

  source  pathetoYourEnv/bin/activate

then run command

python runserver
Answered By: Vinod Ranga

I solved same situation.


python 3.6, django 2.1


I installed Node.js in Windows 10. After python runserver caused error.


File "", line 14
) from exc
SyntaxError: invalid syntax


My python path changed to python-2.7 from python-3.6. (3.6 is correct in my PC.)


Fix python path.

Answered By: Otsuki Takaya

You should start your Virtual Environment,

How to do it?

First with terminal cd into the directory containing

Then type $source <myvenv>/bin/activate
replace with you Virtual Environment name, without angular brackets.

Another issue can that your root directory and venv mis-match.
The structure should be something like this:

     ..some other files

That is your virtual environment and should be in the same folder. Solution to that is to restart the project. If you are facing this error you must haven’t coded anything yet, so restart.

Answered By: rishabh jain

I landed on the same exact exception because I forgot to activate the virtual environment.

Answered By: Billal Begueradj

The following could be the possible reasons,

1. The virtual environment is not enabled
2. The virtual environment is enabled but the python version is different

To create virtual environment

$ virtualenv --python=python3 venv

To activate the virtual environment

$ source venv/bin/activate
Answered By: imbond

I had the exact same error, but then I later found out that I forget to activate the conda environment which had django and other required packages installed.

Solution: Create a conda or virtual environment with django installed,
and activate it before you use the command:

$ python migrate 
Answered By: Sanjay Thapa

I was also getting the same error.
enter image description here

Then I went back to the folder where the environment folder is there and I forgot to activate a Virtual environment so only I was getting this error.
enter image description here

Go to that folder and activate the virtual environment.

$ source env/bin/activate
Answered By: Pooja Khatri

Solved my problem too when I activated my virtual environment using:

source bin/activate
Answered By: Nabila Tajrin

I had this issue (Mac) and followed the instructions on the below page to install and activate the virtual environment

$ cd [ top-level-django-project-dir ]

$ python3 -m pip install –user virtualenv

$ python3 -m venv env

$ source env/bin/activate

Once I had installed and activated the virtual env I checked it

$ which python

Then I installed django into the virtual env

$ pip install django

And then I could run my app

$ python3 runserver

When I got to the next part of the tutorial

$ python startapp polls

I encountered another error:

     File "", line 16

   ) from exc

   SyntaxError: invalid syntax

I removed

from exc

and it then created the polls directory

Answered By: cfranklin

For running Python version 3, you need to use python3 instead of python.

The final command will be:

python3 runserver
Answered By: Parth Patel

The error is generated by using a later version of Django with an old python, probably of version 2.x.

To fix this I had to delete the .venv folder and recreate it with virtualenv -p python3 .venv && source .venv/bin/activate

Answered By: gildniy

The solution is straightforward. the exception from
is because when running the command with python, Django is unable
to predict the exact python version,
say you may have 3.6, 3.5, 3.8 and maybe just one of this versions pip module was used to install Django
to resolve this either use:

./ `enter code here`<command>

or using the exact python version(x.x) stands:

pythonx.x <command>

else the use of virtual environments can come in handy
because its relates any pip django module easily to python version

  • create env with pyenv or virtualenv
  • activate (e.g in virtualenv => virtualenv env)
  • run using python command
Answered By: optimus

Activate your virtual environment then try collecting static files, that should work.

$ source venv/bin/activate
$ python collectstatic
Answered By: Maran Sowthri

You can solve this by adapting the code in your file to the following

#!/usr/bin/env python
import os
import sys

if __name__ == "__main__":
    os.environ.setdefault("DJANGO_SETTINGS_MODULE", "djangochallenge.settings")
        from import execute_from_command_line
    except ImportError:
            import django
        except ImportError:
            raise ImportError(
                "Couldn't import Django. Are you sure it's installed and "
                "available on your PYTHONPATH environment variable? Did you "
                "forget to activate a virtual environment?"

and your server should work fine.

Answered By: Tiago Martins Peres

Same issue occurred to me,But what I did was,

Just Replaced:

python runserver


python3 runserver

in the terminal(macOsX). Because I am using Python version 3.x

Answered By: SudhakarH

I encountered the same error when using pipenv. The issue was caused by not accessing Django correctly from within the virtual environment.

The correct steps using pipenv:

  1. Activate virtual environment: pipenv shell
  2. Install Django: pipenv install django
  3. Create a project: django-admin startproject myproject
  4. Navigate into project folder: cd myproject
  5. Start Django with pipenv: pipenv run python runserver

Note: Pipenv will use the correct python version and pip within the virtual environment.

Answered By: Quintin Henn

This usually happens when Django isn’t installed, and you’re trying to run the file. Run pip3 install django or pip install django or python -m pip install django or python3 -m pip install django to install Django first.

If you think you’ve already installed Django, run pip/pip3/python -m pip/python3 -m pip show django. If you get a Warning: Package(s) not found: django, that means you haven’t installed Django yet.

If you have a virtual environment, run source env/bin/activate to activate the environment on a Unix based system, like a Mac or Linux, where env is the folder in which your virtual environment is contained. On Windows, run envScriptsactivate to activate the environment.

Answered By: user13774796

For me, this code worked

python3 runserver
Answered By: surendra ediga

Here’s a super nerdy way I solved the problem on linux with some extra hidden knowledge. If you know, you know 😉

  1. install vim
sudo apt install vim 
  1. map jj to escape for vim
vim ~/.vimrc
imap jj <Esc>
press the escape key
  1. Use "python" instead of "python3" from now on.
vim ~/.bashrc
alias python=python3
source ~/.bashrc
Answered By: Lane Henslee

Most likely reason is that you did not activate the virtual environment in the project.

To solve it:

  1. Activate the virtual environment
  2. python runserver
Answered By: SweetPotato
Categories: questions Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.