Installing pandas in docker Alpine


I am having a really hard time trying to install a stable data science package configuration in docker. This should be easier with such mainstream, relevant tools.

The following is the Dockerfile that used to work, with a bit of a hack, removing pandas from the package core and installing it separately, specifying pandas<0.21.0, because, allegedly, higher versions conflict with numpy.

    FROM alpine:3.6



RUN apk add --no-cache --virtual build-dependencies python3 
    && apk add --virtual build-runtime 
    build-base python3-dev openblas-dev freetype-dev pkgconfig gfortran 
    && ln -s /usr/include/locale.h /usr/include/xlocale.h 
    && python3 -m ensurepip 
    && rm -r /usr/lib/python*/ensurepip 
    && pip3 install --upgrade pip setuptools 
    && ln -sf /usr/bin/python3 /usr/bin/python 
    && ln -sf pip3 /usr/bin/pip 
    && rm -r /root/.cache 
    && pip install --no-cache-dir $PYTHON_PACKAGES 
    && pip3 install 'pandas<0.21.0'     #<---------- PANDAS
    && apk del build-runtime 
    && apk add --no-cache --virtual build-dependencies $PACKAGES 
    && rm -rf /var/cache/apk/*

# set working directory
WORKDIR /usr/src/app

# add and install requirements
COPY ./requirements.txt /usr/src/app/requirements.txt # other than data science packages go here
RUN pip install -r requirements.txt

# add
COPY ./ /usr/src/app/

RUN chmod +x /usr/src/app/

# add app
COPY . /usr/src/app

# run server
CMD ["/usr/src/app/"]

The configuration above used to work. What happens now is that build does go through, but pandas fails at import with the following error:

ImportError: Missing required dependencies ['numpy']

Since numpy 1.16.1 was installed, I don’t know which numpy pandas is trying to find anymore…

Does anyone know how to obtain a stable solution for this?

NOTE: A solution consisting of a pull from a turnkey docker image for data science with at least the packages mentioned above, into Dockerfile above, would be also very welcomed.


If I move install of data packages into requirements.txt, as suggested in the comments, like so:


numpy==1.16.1 # or numpy==1.16.0
pandas==0.24.1 # or pandas== 0.23.4

and Dockerfile:

# add and install requirements
COPY ./requirements.txt /usr/src/app/requirements.txt
RUN pip install -r requirements.txt

It breaks again at pandas, complaining about numpy.

Collecting numpy==1.16.1 (from -r requirements.txt (line 61))
  Downloading (5.1MB)
Collecting scikit-learn==0.20.2 (from -r requirements.txt (line 62))
  Downloading (10.3MB)
Collecting scipy==1.2.1 (from -r requirements.txt (line 63))
  Downloading (23.1MB)
Collecting nltk==3.4 (from -r requirements.txt (line 64))
  Downloading (1.4MB)
Collecting pandas==0.24.1 (from -r requirements.txt (line 65))
  Downloading (11.8MB)
    Complete output from command python egg_info:
    Traceback (most recent call last):
      File "/usr/local/lib/python3.7/site-packages/pkg_resources/", line 359, in get_provider
        module = sys.modules[moduleOrReq]
    KeyError: 'numpy'

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-_e5z6o6_/pandas/", line 732, in <module>
        ext_modules=maybe_cythonize(extensions, compiler_directives=directives),
      File "/tmp/pip-install-_e5z6o6_/pandas/", line 475, in maybe_cythonize
        numpy_incl = pkg_resources.resource_filename('numpy', 'core/include')
      File "/usr/local/lib/python3.7/site-packages/pkg_resources/", line 1144, in resource_filename
        return get_provider(package_or_requirement).get_resource_filename(
      File "/usr/local/lib/python3.7/site-packages/pkg_resources/", line 361, in get_provider
    ModuleNotFoundError: No module named 'numpy'

Command "python egg_info" failed with error code 1 in /tmp/pip-install-_e5z6o6_/pandas/


This seems like an open pandas issue. For more details please refer to:

pandas-dev github

“Unfortunately, this means that a requirements.txt file is insufficient for setting up a new environment with pandas installed (like in a docker container)”.



  Importing the multiarray numpy extension module failed.  Most
  likely you are trying to import a failed build of numpy.
  Here is how to proceed:
  - If you're working with a numpy git repository, try `git clean -xdf`
    (removes all files not under version control) and rebuild numpy.
  - If you are simply trying to use the numpy version that you have installed:
    your installation is broken - please reinstall numpy.
  - If you have already reinstalled and that did not fix the problem, then:
    1. Check that you are using the Python you expect (you're using /usr/local/bin/python),
       and that you have no directories in your PATH or PYTHONPATH that can
       interfere with the Python and numpy versions you're trying to use.
    2. If (1) looks fine, you can open a new issue at  Please include details on:
       - how you installed Python
       - how you installed numpy
       - your operating system
       - whether or not you have multiple versions of Python installed
       - if you built from source, your compiler versions and ideally a build log


requirements.txt —>


As of 01/12/20, the accepted solution started not to work anymore.
Now, build breaks not at pandas, but at scipy but after numpy, while building scipy's wheel. This is the log:

  ERROR: Failed building wheel for scipy
  Running clean for scipy
  ERROR: Command errored out with exit status 1:
   command: /usr/bin/python3.6 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-s6nahssd/scipy/'"'"'; __file__='"'"'/tmp/pip-install-s6nahssd/scipy/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' clean --all
       cwd: /tmp/pip-install-s6nahssd/scipy
  Complete output (9 lines):

  ` clean` is not supported, use one of the following instead:

    - `git clean -xdf` (cleans all files)
    - `git clean -Xdf` (cleans all versioned files, doesn't touch
                        files that aren't checked into the git repo)

  Add `--force` to your command to use it anyway if you must (unsupported).

  ERROR: Failed cleaning build dir for scipy
Successfully built numpy
Failed to build scipy
ERROR: Could not build wheels for scipy which use PEP 517 and cannot be installed directly

From the error it seems that building process is using python3.6, while I use FROM alpine:3.7.

Full log here ->

And this is the current Dockerfile:

Asked By: 8-Bit Borges



Try adding this to your requirements.txt file:


I’ve been facing the same error since yesterday and this change solved it for me.

Answered By: Ram Krishnan

If you’re not bound to Alpine 3.6, using Alpine 3.7 (or later) should work.

On Alpine 3.6, installing matplotlib failed for me with the following:

Collecting matplotlib
  Downloading (36.6MB)
    Complete output from command python egg_info:
    Download error on [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:833) -- Some packages may not be found!
    Couldn't find index page for 'numpy' (maybe misspelled?)
    Download error on [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:833) -- Some packages may not be found!
    No local packages or working download links found for numpy>=1.10.0

However, on Alpine 3.7, it worked. This may be due to a numpy versioning issue (see here), but I’m not able to tell for sure. Past that problem, packages were built and installed successfully – taking a good while, about 30 minutes (since Alpine’s musl-libc is not compatible to Python’s Wheels format, all packages installed with pip have to be built from source).

Note that one important change is needed: you should only remove the build-runtime virtual package (apk del build-runtime) after pip install. Also, if applicable, you could replace numpy 1.16.1 with 1.16.2, which is the shipped version (otherwise 1.16.2 will be uninstalled and 1.16.1 built from source, further increasing the build time) – I haven’t tried this, though.

For reference, here’s my slightly modified Dockerfile and docker build output.


Usually Alpine is chosen as the base for minimizing the image size (Alpine is also otherwise very slick, but has compatibility issues with mainland Linux apps due to glibc/musl). Having to build Python packages from source kind of beats that purpose, since you get a very bloated image – 900MB before any cleanup, which also takes ages to build. The image could be greatly compacted by removing all intermediate compilation artifacts, build dependencies etc., but still.

If you can’t get the Python package versions you need to work on Alpine, without having to build them from source, I would suggest trying other small and more compatible base images such as debian-slim, or even ubuntu.


Following “Edit 3” with added requirements, here are updated Dockerfile and Docker build output.
The following packages were added for satisfying build dependencies:

postgresql-dev libffi-dev libressl-dev libxml2 libxml2-dev libxslt libxslt-dev libjpeg-turbo-dev zlib-dev

For packages that failed to build due to specific headers, I used Alpine’s package contents search to locate the missing package.
Specifically for cffi, the ffi.h header was missing, which needs the libffi-dev package:

Alternatively, when a package build failure is not very clear, the installation instructions of the specific package could be referred to, for example, Pillow.

The new image size, before any compaction, is 1.04GB. For cutting it down a bit, you could remove the Python and pip caches:

RUN apk del build-runtime && 
    find -type d -name __pycache__ -prune -exec rm -rf {} ; && 
    rm -rf ~/.cache/pip

This will bring image size down to 661MB, when using docker build --squash.

Answered By: valiano

This may not be completely relevant, since this the first answer that pops up when searching for numpy/pandas installation failed in Alpine, I am adding this answer.

The following fix worked for me(But it takes longer to install pandas/numpy)

apk update
apk --no-cache add curl gcc g++
ln -s /usr/include/locale.h /usr/include/xlocale.h

Now try installing pandas/numpy

Answered By: codeslord

An older Q&A at Why does it take ages to install Pandas on Alpine Linux relates.

If your aim to get a stable solution without knowing the nuts and bolts, for python 3 you can just build off the following (copy & paste of my answer from

FROM python:3.7-alpine
RUN echo "@testing" >> /etc/apk/repositories
RUN apk add --update --no-cache py3-numpy py3-pandas@testing

If your goal is to understand how to achieve a stable build, the discussion there and related images might help too…

Answered By: jtlz2

FROM python:3.8-alpine

RUN apk –update add gcc build-base freetype-dev libpng-dev openblas-dev

RUN pip install –no-cache-dir matplotlib pandas

Answered By: olorunshola matins
Categories: questions Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.