"UserWarning: Matplotlib is currently using agg, which is a non-GUI backend, so cannot show the figure." when plotting figure with pyplot on Pycharm


I am trying to plot a simple graph using pyplot, e.g.:

import matplotlib.pyplot as plt

but the figure does not appear and I get the following message:

UserWarning: Matplotlib is currently using agg, which is a non-GUI backend, so cannot show the figure.

I saw in several places that one had to change the configuration of matplotlib using the following:

import matplotlib
import matplotlib.pyplot as plt

I did this, but then got an error message because it cannot find a module:

ModuleNotFoundError: No module named 'tkinter'

Then, I tried to install “tkinter” using pip install tkinter (inside the virtual environment), but it does not find it:

Collecting tkinter
  Could not find a version that satisfies the requirement tkinter (from versions: )
No matching distribution found for tkinter

I should also mention that I am running all this on Pycharm Community Edition IDE using a virtual environment, and that my operating system is Linux/Ubuntu 18.04.

I would like to know how I can solve this problem in order to be able to display the graph.

Asked By: johnwolf1987



Try import tkinter because pycharm already installed tkinter for you, I looked Install tkinter for Python

You can maybe try:

import tkinter
import matplotlib
import matplotlib.pyplot as plt

as a tkinter-installing way

I’ve tried your way, it seems no error to run at my computer, it successfully shows the figure. maybe because pycharm have tkinter as a system package, so u don’t need to install it. But if u can’t find tkinter inside, you can go to Tkdocs to see the way of installing tkinter, as it mentions, tkinter is a core package for python.

Answered By: okie

Solution 1: is to install the GUI backend tk

I found a solution to my problem (thanks to the help of ImportanceOfBeingErnest).

All I had to do was to install tkinter through the Linux bash terminal using the following command:

sudo apt-get install python3-tk

instead of installing it with pip or directly in the virtual environment in Pycharm.

Solution 2: install any of the matplotlib supported GUI backends

  • solution 1 works fine because you get a GUI backend… in this case the TkAgg
  • however you can also fix the issue by installing any of the matplolib GUI backends like Qt5Agg, GTKAgg, Qt4Agg, etc
    • for example pip install pyqt5 will fix the issue also


  • usually this error appears when you pip install matplotlib and you are trying to display a plot in a GUI window and you do not have a python module for GUI display.
  • The authors of matplotlib made the pypi software deps not depend on any GUI backend because some people need matplotlib without any GUI backend.
Answered By: johnwolf1987

In my case, the error message was implying that I was working in a headless console. So plt.show() could not work. What worked was calling plt.savefig:

import matplotlib.pyplot as plt

plt.plot([1, 2, 3], [5, 7, 4])

I found the answer on a github repository.

Answered By: vvvvv

If you use Arch Linux (distributions like Manjaro or Antegros) simply type:

sudo pacman -S tk

And all will work perfectly!

Answered By: dexXxed

I too had this issue in PyCharm. This issue is because you don’t have tkinter module in your machine.

To install follow the steps given below (select your appropriate os)

For ubuntu users

 sudo apt-get install python-tk


 sudo apt-get install python3-tk

For Centos users

 sudo yum install python-tkinter


 sudo yum install python3-tkinter

for Arch Users

  sudo pacman -S tk


  sudo pamac install tk

For Windows, use pip to install tk

After installing tkinter restart your Pycharm and run your code, it will work

Answered By: Arjun Kumar

Linux Mint 19. Helped for me:

sudo apt install tk-dev

P.S. Recompile python interpreter after package install.

Answered By: Michael Sizonenko

Just in case if this helps anybody.

Python version: 3.7.7
platform: Ubuntu 18.04.4 LTS

This came with default python version 3.6.9, however I had installed my own 3.7.7 version python on it (installed building it from source)

tkinter was not working even when the help('module') shows tkinter in the list.

The following steps worked for me:

  1. sudo apt-get install tk-dev.

rebuild the python:
1. Navigate to your python folder and run the checks:

cd Python-3.7.7
sudo ./configure --enable-optimizations
  1. Build using make command:
    sudo make -j 8 — here 8 are the number of processors, check yours using nproc command.
  2. Installing using:

    sudo make altinstall

Don’t use sudo make install, it will overwrite default 3.6.9 version, which might be messy later.

  1. Check tkinter now
    python3.7 -m tkinter

A windows box will pop up, your tkinter is ready now.

Answered By: Divas

After upgrading lots of packages (Spyder 3 to 4, Keras and Tensorflow and lots of their dependencies), I had the same problem today! I cannot figure out what happened; but the (conda-based) virtual environment that kept using Spyder 3 did not have the problem. Although installing tkinter or changing the backend, via matplotlib.use('TkAgg) as shown above, or this nice post on how to change the backend, might well resolve the problem, I don’t see these as rigid solutions. For me, uninstalling matplotlib and reinstalling it was magic and the problem was solved.

pip uninstall matplotlib

… then, install

pip install matplotlib

From all the above, this could be a package management problem, and BTW, I use both conda and pip, whenever feasible.

Answered By: Mohd

When I ran into this error on Spyder, I changed from running my code line by line to highlighting my block of plotting code and running that all at once. Voila, the image appeared.

Answered By: GuyStalks

You can change the matplotlib using backend using the from agg to Tkinter TKAgg using command

matplotlib.use('TKAgg',warn=False, force=True)
Answered By: Shahir Ansari

Simple install

pip3 install PyQt5==5.9.2

It works for me.

Answered By: Manish Gupta

I added %matplotlib inline
and my plot showed up in Jupyter Notebook.

Answered By: chinelo Okafor

The comment by @xicocaio should be highlighted.

tkinter is python version-specific in the sense that sudo apt-get install python3-tk will install tkinter exclusively for your default version of python. Suppose you have different python versions within various virtual environments, you will have to install tkinter for the desired python version used in that virtual environment. For example, sudo apt-get install python3.7-tk. Not doing this will still lead to No module named ' tkinter' errors, even after installing it for the global python version.

Answered By: Hari

This worked with R reticulate. Found it here.

1: matplotlib.use( 'tkagg' )
2: matplotlib$use( 'tkagg' )

For example:

import numpy as np
import matplotlib.pyplot as plt
from matplotlib import style

import matplotlib
matplotlib.use( 'tkagg' )

from sklearn import svm

x = [1, 5, 1.5, 8, 1, 9]
y = [2, 8, 1.8, 8, 0.6, 11]

Answered By: Kasut William

issue = “UserWarning: Matplotlib is currently using agg, which is a non-GUI backend, so cannot show the figure.”

And this worked for me

import matplotlib
import matplotlib.pyplot as plt
Answered By: dinuka dilshan

I installed python3-tk , on Ubuntu 20.04 and using WSL2

    import numpy as np
    import matplotlib.pyplot as plt
    import matplotlib
    matplotlib.use( 'tkagg')

and then I installed GWSL from the Windows Store which seems to solve problem of WSL2 rendering out of the box

Answered By: Agrover112

I have solved it by putting matplotlib.use('TkAgg') after all import statements.
I use python 3.8.5 VSCODE and anaconda.
No other tricks worked.

Answered By: Dpappala

If you install python versions using pyenv on Debian-based systems, be sure to run sudo apt install tk-dev before pyenv install. If it’s already installed, remove it with pyenv uninstall and install it again after install tk-dev. Therefore, there is no need to set any env variables when running pyenv install.

Answered By: Fábio

Works if you use some third party code in your project. It probably contains the following line


Search for it and comment it out.

If you have no clue about what it is you are probably not using this part of the code.

Solutions about using another backend GUI may be cleaner, so choose your fighter.

Answered By: user9393410

The answer has been given a few times but it is not obvious, one needs to install graphics, this works.

pip3 install PyQt5
Answered By: peterretief

If using Jupyter notebook try the following:

%matplotlib inline

This should render the plot even if not specifying the



Answered By: Rodrigo Xavier G

The solution that worked for me:

  1. Install tkinter

  2. import tkinter into the module

  3. make sure that matplotlib uses (TkAgg) instead of (Agg)


Answered By: wingstop-fries

Beware of the import order in your code, I spent a whole day going through this answers and ended up solving the problem by importing bt before anything else and then using the .use('TkAgg') statement (for some reason importing bt changes the matplotlib backend to ‘Agg’)

Answered By: David Posada

execute the following command before plotting

%matplotlib inline

Another option is to install Anaconda. It is a useful software where you can create many environments and there are many libraries already installed for data science and machine learning.

–Edit —

Here there are steps that help me to fix your same issue:

  • Step 1: Download .exe on the official page: Anaconda, use the individual edition because it is the free ones: Anaconda Individual
  • Step 2: Once you have installed the program, open in end go to the env section
    enter image description here

In this section, you can create many env as you prefer, i.e I have 2 env one for my main base (root) one for the last version of python.

  • Step 3: creating the py env in this section, Anaconda will install automatically the main libraries used by developers, decreasing the risk of getting Errors on your code.

  • Additional Consideration: as you can see in the snap below you can easily see which libraries have you installed in your conda. I got your same that error because i missed one of that 3 libs
    enter image description here

Hope was useful and clear to understand!

Answered By: user15606993

For Windows 10, if using pip install tk does not work for you, try:

  • Download and run official python installer for windows. Even if you
    already have it downloaded, run it again.
  • When (re)installing python, make sure you chose "advanced" options, and
    set the checkbox "tcl/tk and IDLE" to true.
  • If you already had python installed, select the "Modify" option, and
    make sure that checkbox is selected.

Source of my fix:

Answered By: NobodySomewhere

%matplotlib inline
Once fixed the problem for me.
I found the answer here: When I use matplotlib in jupyter notebook,it always raise " matplotlib is currently using a non-GUI backend" error?
by user Mulugeta Weldezgina

adding %matplotlib inline while importing helps for smooth plots in

%matplotlib inline
import matplotlib.pyplot as plt

%matplotlib inline sets the backend of matplotlib to the ‘inline’
With this backend, the output of plotting commands is displayed inline
within frontends like the Jupyter notebook, directly below the code
cell that produced it. The resulting plots will then also be stored in
the notebook document.

My problem started after I used pandas_profile (or something like that), and running %matplotlib inline once fixed the background from being headless etc.

Answered By: user96265

This will solve the issue. It works well in jupyter.

%matplotlib inline
Answered By: tushar patange


%matplotlib inline

I had the same problem and it worked for me. I tested it on my Jupyter notebooks and visual studio code, so you should have no problems.

Answered By: Felipe Araya Olea

On Mac OS, I made it work with:

import matplotlib
Answered By: lubumbax

None of these answers worked for me using Pycharm Professional edition 2021.3

Regular matplotlib graphs did work on the scientific view, but it did not allow me to add images to the plots.

What did work for me is adding this line before I try plotting anything:


Answered By: knowledge_seeker

On WSL with X server

Make sure that your X server work. Matplotlib indicate this error if he can’t connect to the X display.

Windows Firewall configuration

Pay attention to the windows firewall ! I changed from WSL Debian to Ubuntu and didn’t remember about the firewall rule.
I use this post to configure the windows firewall rule to make the X server work. This method avoid too permisive rule that able anyone to use your X server.

It said :

If you already had installed an X11 server, Windows may have created firewall rules that will mess with the above configuration. Search for them and delete them in "Windows Defender Firewall with Advanced Security."

You will now need to configure Windows Firewall to permit connections from WSL2 to the X11 display server. You will install the display server in the next step. We do this step first to avoid Windows Firewall from auto-creating an insecure firewall rule when you run the X11 display server. Many guides on X11 forwarding and WSL2 make this firewall rule too permissive, allowing connections from any computer to your computer. This means someone could theoretically, if they are on your same network, start sending graphical display information to your computer.

To avoid this, we will make Windows Firewall only accept internet traffic from the WSL2 instance.

To set this up, you can copy the below to a script and run it from within WSL2:

LINUX_IP=$(ip addr | awk '/inet / && !/ {split($2,a,"/"); print a[1]}')
WINDOWS_IP=$(ip route | awk '/^default/ {print $3}')
# Elevate to administrator status then run netsh to add firewall rule
powershell.exe -Command "Start-Process netsh.exe -ArgumentList "advfirewall firewall add rule name=X11-Forwarding dir=in action=allow program=%ProgramFiles%VcXsrvvcxsrv.exe localip=$WINDOWS_IP remoteip=$LINUX_IP localport=6000 protocol=tcp" -Verb RunAs"

Manual method :

Alternatively, you can manually add the rule through a GUI by doing the following:

  1. Open "Windows Defender Firewall with Advanced Security"
  2. Click add new rule brings up the New Rule Wizard (next to navigate between each section):
    • Rule type: Custom
    • Program: "This program path:" %ProgramFiles%VcXsrvvcxsrv.exe
    • Protocol and ports
    • Protocol type: TCP
    • Local port: 6000
    • Remote port: any
    • Scope
      • Local IP address: Obtain the IP address to put in by running the below command in WSL2
        ip route | awk '/^default/ {print $3}'
    • remote IP addresses
      • Obtain IP address to enter by running the below in WSL2
        ip addr | awk '/inet / && !/ {split($2,a,"/"); print a[1]}'
    • Action: "Allow the connection
    • Profile: Selection Domain, Private, and Public
    • Name: "X11 forwarding"
Answered By: vaine4

Ubuntu 20.04 command line setup. I install the following to make Matplotlib stop throwing the error UserWarning: Matplotlib is currently using agg, which is a non-GUI backend, so cannot show the figure.

I installed python-tk through the steps:

apt-get update

apt-get install python3.8-tk
Answered By: GigaWatts

I have had the same problem with Windows 7 and PyCharm Pro.
It happened after I’d installed the financial package "ffn", so after

import ffn

the Matplotlib backend had changed to "add".
You can check the current backend by:


You can change the current backend by:

matplotlib.use(backend = "module://backend_interagg")

Which worked for my issue with PyCharm Professional in an additional or internal window.

Answered By: Bem Ostap

the solution of this problem is:
make sure put this line

%matplotlib inline

in the head of your code

like that

# In an IPython notebook¶
# This magic just sets up matplotlib's interactive mode
%matplotlib inline
# So you have to explicitely import the module into the namespace
import matplotlib.pyplot as pl
import numpy as np
# Create the figure object
fig = pl.figure(figsize=(12, 8))
x = np.arange(0, 4 * np.pi, 0.1)
y = np.sin(x)
pl.plot(x, y)

%matplotlib inline turns on “inline plotting”, where plot graphics will appear in your notebook. This has important implications for interactivity: for inline plotting, commands in cells below the cell that outputs a plot will not affect the plot. For example, changing the color map is not possible from cells below the cell that creates a plot. However, for other backends, such as qt4, that open a separate window, cells below those that create the plot will change the plot – it is a live object in memory. If you are not using matplotlib in interactive mode at all, figures will only appear if you invoke

for more information about %matplotlib inline see this link

Answered By: Chafik Boulealam
Categories: questions Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.