pip no longer working after update error 'module' object is not callable


After a pip update, pip has stopped working completely.

Z:>pip install matplotlib
Traceback (most recent call last):
  File "c:program filespython37librunpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "c:program filespython37librunpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "C:Program FilesPython37Scriptspip.exe__main__.py", line 9, in <module>
TypeError: 'module' object is not callable

Any help please?

Edit: I am working on windows 10

Asked By: Agustin



All credit for this goes to user han_solo, who left the answer as a comment, instead of as an answer:

Instead of pip install stdlib_list --user

use python -m pip install stdlib_list --user

Replace stdlib_list with matplotlib or whatever the name is of the package you want.

Answered By: Toothpick Anemone

I’ve had the same issue as you, and I solved it uninstalling pip and installing again.

To uninstall:
python -m pip uninstall pip

To install, follow the instructions:

After that you will going to have a older but functional 19.0.3 version.

Answered By: rdemarqui

Similar to what @han_solo said, but if your running python3, instead of using:

python -m pip install stdlib_list --user

try using:

python3 -m pip install stdlib_list --user

Answered By: Alden DelVecchio

Have the habit of installing any python packages with pip using python -m, say for installing numpy use below command:

python -m pip install numpy

In case if it errros out with the environment permission error append –user in the same command:

python -m pip install numpy –user

Answered By: Piyush Upadhyay

Had the same problem. I’ve managed to fix it by reinstalling pip in place, using combination the other answers:

python -m pip install -U --force-reinstall pip

Answered By: Michal Sylwester

If you do not wish to use the long command every time python -m pip install <package>, reinstall pip to the older version where this error wasn’t there.

python -m pip install pip==19.0.3

Now you will be able to use pip install matplotlib or pip list normally.

And whenever the bug is resolved, upgrade pip like you did before.

Answered By: mudit

This worked for me, uninstall pip 19.3.1 and replace with 19.0.3, error gone.

python -m pip install pip==19.0.3 --user
Answered By: Camilo Caquimbo

I had the same issue with h5py-2.7.1, and the warnings were gone after upgrading to h5py-2.10.0.

Answered By: Ashkan

I cannot leave the comments yet, therefore I’ve decided to leave a link with an explanation why this can happen: https://github.com/pypa/pip/issues/5599

If this is the case you can try to fix it by downgrading the pip version with the following command:

 python -m pip install pip==<previous version>
Answered By: dimi_mel

in one case, from your python file do this edit to your IMPORT

--import [MODULE]
++from [MODULE_NAME] import [MODULE]
Answered By: Samuel Frimpong
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.