No module named pkg_resources


I’m deploying a Django app to a dev server and am hitting this error when I run pip install -r requirements.txt:

Traceback (most recent call last):
  File "/var/www/mydir/virtualenvs/dev/bin/pip", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources

pkg_resources appears to be distributed with setuptools. Initially I thought this might not be installed to the Python in the virtualenv, so I installed setuptools 2.6 (same version as Python) to the Python site-packages in the virtualenv with the following command:

sh setuptools-0.6c11-py2.6.egg --install-dir /var/www/mydir/virtualenvs/dev/lib/python2.6/site-packages

EDIT: This only happens inside the virtualenv. If I open a console outside the virtualenv then pkg_resources is present, but I am still getting the same error.

Any ideas as to why pkg_resources is not on the path?

Asked By: igniteflow



July 2018 Update

Most people should now use pip install setuptools (possibly with sudo).

Some may need to (re)install the python-setuptools package via their package manager (apt-get install, yum install, etc.).

This issue can be highly dependent on your OS and dev environment. See the legacy/other answers below if the above isn’t working for you.


This error message is caused by a missing/broken Python setuptools package. Per Matt M.’s comment and setuptools issue #581, the bootstrap script referred to below is no longer the recommended installation method.

The bootstrap script instructions will remain below, in case it’s still helpful to anyone.

Legacy Answer

I encountered the same ImportError today while trying to use pip. Somehow the setuptools package had been deleted in my Python environment.

To fix the issue, run the setup script for setuptools:

wget -O - | python

(or if you don’t have wget installed (e.g. OS X), try

curl | python

possibly with sudo prepended.)

If you have any version of distribute, or any setuptools below 0.6, you will have to uninstall it first.*

See Installation Instructions for further details.

* If you already have a working distribute, upgrading it to the “compatibility wrapper” that switches you over to setuptools is easier. But if things are already broken, don’t try that.

Answered By: cwc

I had this problem when I had activated my virtualenv as a different user than the one who created it. It seems to be a permission problem. I discovered this when I tried the answer by @cwc and saw this in the output:

Installing easy_install script to /path/env/bin
error: /path/env/bin/easy_install: Permission denied

Switching back to the user that created the virtualenv, then running the original pip install command went without problems. Hope this helps!

Answered By: Martijn de Milliano

I had this problem today as well. I only got the problem inside the virtual env.

The solution for me was deactivating the virtual env, deleting and then uninstalling virtualenv with pip and reinstalling it. After that I created a new virtual env for my project, then pip worked fine both inside the virtual environment as in the normal environment.

Answered By: arno_v

It also happened to me. I think the problem will happen if the requirements.txt contains a “distribute” entry while the virtualenv uses setuptools. Pip will try to patch setuptools to make room for distribute, but unfortunately it will fail half way.

The easy solution is delete your current virtualenv then make a new virtualenv with –distribute argument.

An example if using virtualenvwrapper:

$ deactivate
$ rmvirtualenv yourenv
$ mkvirtualenv yourenv --distribute
$ workon yourenv
$ pip install -r requirements.txt
Answered By: pram

I have seen this error while trying to install rhodecode to a virtualenv on ubuntu 13.10. For me the solution was to run

pip install --upgrade setuptools
pip install --upgrade distribute 

before I run easy_install rhodecode.

Answered By: Ali Akdurak

I fixed the error with virtualenv by doing this:

Copied from




This may be a cheap workaround, but it worked for me.


If setup tools doesn’t exist, you can try installing system-site-packages by typing virtualenv --system-site-packages /DESTINATION DIRECTORY, changing the last part to be the directory you want to install to. will be under that directory in lib/python2.7/site-packages

Answered By: mrgnw

For me, this error was being caused because I had a subdirectory called “site”! I don’t know if this is a pip bug or not, but I started with:


pip install -r requirements.txt wouldn’t work, giving me the above error!

renaming the subfolder from “site” to “src” fixed the problem! Maybe pip is looking for “site-packages”? Crazy.

Answered By: jdg

I had this error earlier and the highest rated answer gave me an error trying to download the file. I found another source so you can run the command:

curl | python

I found that I also had to use sudo to get it working, so you may need to run:

sudo curl | sudo python

I’ve also created another location that the script can be downloaded from:

Answered By: ajtrichards

I came across this answer when I was trying to follow this guide for OSX. What worked for me was, after running python get-pip, I had to ALSO easy_install pip. That fixed the issue of not being able to run pip at all. I did have a bunch of old macport stuff installed. That may have conflicted.

Answered By: KitsuneYMG

Apparently you’re missing setuptools. Some virtualenv versions use distribute instead of setuptools by default. Use the --setuptools option when creating the virtualenv or set the VIRTUALENV_SETUPTOOLS=1 in your environment.

Answered By: Danilo Bargen

On windows, I installed pip downloaded from then encontered this problem.

So I should have installed setuptools(easy_install) first.

Answered By: thinker3
sudo apt-get install --reinstall python-pkg-resources

fixed it for me in Debian. Seems like uninstalling some .deb packages (twisted set in my case) has broken the path python uses to find packages

Answered By: Marek

In CentOS 6 installing the package python-setuptools fixed it.

yum install python-setuptools
Answered By: Paul

just reinstall your setuptools by :

$ sudo wget
$ tar -zxvf setuptools-0.6c11.tar.gz
$ cd setuptools-0.6c11/
$ sudo python build
$ sudo python install
$ sudo pip install --upgrade setuptools

then everything will be fine.

Answered By: Scott Yang

I use CentOS 6.7, and my python was just upgrade from 2.6.6 to 2.7.11, after tried so many different answer, finally the following one does the job:

sudo yum install python-devel

Hope help someone in the same situation.

Answered By: shellbye

Looks like they have moved away from bitbucket and are now on github (

Command to run is:

wget -O - | sudo python
Answered By: shadyhill

None of the posted answers worked for me, so I reinstalled pip and it worked!

sudo apt-get install python-setuptools python-dev build-essential 

sudo easy_install pip 

pip install --upgrade setuptools


Answered By: user13107

For me, it turned out to be a permissions problem on site-packages. Since it’s only my dev environment, I raised the permissions and everything is working again:

sudo chmod -R a+rwx /path/to/my/venv/lib/python2.7/site-packages/
Answered By: kat

I ran into this problem after updating my Ubuntu build. It seems to have gone through and removed set up tools in all of my virtual environments.

To remedy this I reinstalled the virtual environment back into the target directory. This cleaned up missing setup tools and got things running again.


~/RepoDir/TestProject$ virtualenv TestEnvironmentDir
Answered By: Steve D.

For me a good fix was to use --no-download option to virtualenv (VIRTUALENV_NO_DOWNLOAD=1 tox for tox.)

Answered By: Baczek

On Opensuse 42.1 the following fixed this issue:

zypper in python-Pygments
Answered By: David Hamner

Needed a little bit more sudo. Then used easy_install to install pip. Works.

sudo wget -O - | sudo python
sudo easy_install pip
Answered By: Tarion

ImportError: No module named pkg_resources: the solution is to reinstall python pip using the following Command are under.

Step: 1 Login in root user.

sudo su root

Step: 2 Uninstall python-pip package if existing.

apt-get purge -y python-pip

Step: 3 Download files using wget command(File download in pwd )


Step: 4 Run python file.

python ./

Step: 5 Finaly exicute installation command.

apt-get install python-pip

Note: User must be root.

Answered By: Tukadiya Ramesh

I experienced that error in my Google App Engine environment. And pip install -t lib setuptools fixed the issue.

Answered By: Murat Çorlu

After trying several of these answers, then reaching out to a colleague, what worked for me on Ubuntu 16.04 was:

pip install --force-reinstall -U setuptools
pip install --force-reinstall -U pip

In my case, it was only an old version of pillow 3.1.1 that was having trouble (pillow 4.x worked fine), and that’s now resolved!

Answered By: ptim

If you are using Python 3, you should use pip3 instead of pip. The command looks like $ pip3 install requirements.txt

Answered By: than7

I have had the same problem when I used easy-install to install pip for python 2.7.14. For me the solution was (might not be the best, but worked for me, and this is probably the simplest) that the folder that contained the also contained a folder pkg_resources, and i have copy-pasted this folder into the same folder where my script was (python27Scripts).
Since then, I found it in the python27Libsite-packagespip-9.0.1-py2.7.eggpip_vendor folder as well, it might be a better solution to modify the file to import this.

Answered By: B Kasza

yum -y install python-setuptools

i configure the Ceph there is a problem execute command "$ ceph-deploy new node1",
and I execute the command "$ yum -y install python-setuptools",
then the problem is gone.Thanks

Answered By: Lucas

If you are encountering this issue with an application installed via conda, the solution (as stated in this bug report) is simply to install setup-tools with:

conda install setuptools
Answered By: Gabriel

On Windows, with python 3.7, this worked for me:

pip install --upgrade setuptools --user

--user installs packages in your home directory, which doesn’t require admin privileges.

Answered By: David Jablonski

In my case, I had 2 python versions installed initially and later I had deleted the older one. So while creating the virtual environment

virtualenv venv

was referring to the uninstalled python

What worked for me

python3 -m virtualenv venv

Same is true when you are trying to use pip.

the simple resoluition is that you can use conda to upgrade setuptools or entire enviroment. (Specially for windows user.)

conda upgrade -c anaconda setuptools

if the setuptools is removed, you need to install setuptools again.

conda install -c anaconda setuptools

if these all methodes doesn’t work, you can upgrade conda environement. But I do not recommend that you need to reinstall and uninstall some packages because after that it will exacerbate the situation.

Answered By: weibin Wang

A lot of answers are recommending the following but if you read through the source of that script, you’ll realise it’s deprecated.

wget -O - | python

If your pip is also broken, this won’t work either.

pip install setuptools

I found I had to run the command from Ensure pip, setuptools, and wheel are up to date, to get pip working again.

python -m pip install --upgrade pip setuptools wheel
Answered By: Everett Toews

You can use the command
sudo apt-get install --reinstall python3-pkg-resources
if you are using python3 , this was the case with me.

Answered By: Meghraj pardesi

I ran into this problem after installing the latest Python version 3.10.4.
Somehow, the setuptools package and pip were deleted.

I used the following command to resolve the issue :
in [Windows]

py -m ensurepip --default-pip
Answered By: dineshsundaram

In my case, I did:

pip install -U poetry
Answered By: Luís Soares

I encountered this error in a poetry environment.

Steps I took to resolve it:

  1. Add setuptools as a dev dependency with
poetry add --dev setuptools
  1. Install setuptools in the poetry env using
poetry run pip install setuptools
Answered By: Eugene Brown

I caused this error (or very similar) by removing the "/Library/Python/2.7/site-packages/" directory from my machine thinking it was a local cache. Only easy_install stopped working (pip was fine).

None of the items listed here helped me but I was able to recover by downloading the latest from and installing it. Luckily I was not on latest, as I believe otherwise I would have had to reinstall.

I suspect (but not 100% sure) I also needed to open a new terminal (or new tab in terminal) to have it work.

Answered By: joedragons