How to pip install a package with min and max version range?


I’m wondering if there’s any way to tell pip, specifically in a requirements file, to install a package with both a minimum version (pip install package>=0.2) and a maximum version which should never be installed (theoretical api: pip install package<0.3).

I ask because I am using a third party library that’s in active development. I’d like my pip requirements file to specify that it should always install the most recent minor release of the 0.5.x branch, but I don’t want pip to ever try to install any newer major versions (like 0.6.x) since the API is different. This is important because even though the 0.6.x branch is available, the devs are still releasing patches and bugfixes to the 0.5.x branch, so I don’t want to use a static package==0.5.9 line in my requirements file.

Is there any way to do that?

Asked By: coredumperror



You can do:

$ pip install "package>=0.2,<0.3"

And pip will look for the best match, assuming the version is at least 0.2, and less than 0.3.

This also applies to pip requirements files. See the full details on version specifiers in PEP 440.

Answered By: Hugo Tavares

you can also use:

pip install package==0.5.*

which is more consistent and easy to read.

Answered By: lowrin

An elegant method would be to use the ~= compatible release operator according to PEP 440. In your case this would amount to:


As an example, if the following versions exist, it would choose 0.5.9:

  • 0.5.0
  • 0.5.9
  • 0.6.0

For clarification, each pair is equivalent:

~= 0.5.0
>= 0.5.0, == 0.5.*

~= 0.5
>= 0.5, == 0.*
Answered By: Moritz is an interactive tool for developers to test defined specifiers for version handling.

enter image description here

Related to the question:

Answered By: Darius
Categories: questions Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.