ImportError: No module named PIL


I use this command in the shell to install PIL:

easy_install PIL

then I run python and type this: import PIL. But I get this error:

Traceback (most recent call last):
  File "<console>", line 1, in <module>
ImportError: No module named PIL

I’ve never had such problem, what do you think?

Asked By: Asma Gheisari



You are probably missing the python headers to build pil. If you’re using ubuntu or the likes it’ll be something like

apt-get install python-dev
Answered By: Crankyadmin

On some installs of PIL, you must do

import Image

instead of import PIL (PIL is in fact not always imported this way). Since import Image works for you, this means that you have in fact installed PIL.

Having a different name for the library and the Python module is unusual, but this is what was chosen for (some versions of) PIL.

You can get more information about how to use this module from the official tutorial.

PS: In fact, on some installs, import PIL does work, which adds to the confusion. This is confirmed by an example from the documentation, as @JanneKarila found out, and also by some more recent versions of the MacPorts PIL package (1.1.7).

Answered By: Eric O. Lebigot

Sometimes I get this type of error running a Unitest in python. The solution is to uninstall and install the same package on your virtual environment.

Using this commands:

pip uninstall PIL


pip install  PIL 

If for any reason you get an error, add sudo at the beginning of the command and after hitting enter type your password.

Answered By: Fernando Munoz

On windows, try checking the path to the location of the PIL library. On my system, I noticed the path was

Python26Libsite-packagespil instead of Python26Libsite-packagesPIL  

after renaming the pil folder to PIL, I was able to load the PIL module.

Answered By: Komla

On a different note, I can highly recommend the use of Pillow which is backwards compatible with PIL and is better maintained/will work on newer systems.

When that is installed you can do

import PIL 


from PIL import Image


Answered By: Damian

In shell, run:

pip install Pillow

Attention: PIL is deprecated, and pillow is the successor.

Answered By: zhiming wang

I had the same issue while importing PIL and further importing the ImageTk and Image modules. I also tried installing PIL directly through pip. but not success could be achieved. As in between it has been suggested that PIL has been deprectaed, thus, tried to install pillow through pip only. pillow was successfully installed, further, the PIL package was made under the path : python27/Lib/site-packages/.

Now both Image and ImageTk could be imported.

Answered By: Prateek Jain

I recently installed Leap. I Tried openshot and it didn’t start. So came here and found a suggestion to start from the Terminal to see if there were any error.

The error I had was error missing mlt. So I installed the python-mlt module from Yast and imported it, tried to start but next openshot said missing pil.

I Followed the Pillow suggestion to install because Yast couldn’t find any pil and imported pil. That went ok but did not start and showed Error missing goocanvas.

The I installed goocanvas with Yast, imported it in python, and Openshot fired up !!

With a lot of errors in the terminal like missing Vimeoclient and lots of attributeerrors. Well, will see if it is of any influence working with it.

Answered By: Johan

At first install Pillow with

pip install Pillow

or as follows

c:Python35>python -m pip install Pillow

Then in python code you may call

from PIL import Image

“Pillow is a fork of PIL, the Python Imaging Library, which is no longer maintained. However, to maintain backwards compatibility, the old module name is used.” From pillow installed, but "no module named pillow" – python2.7 – Windows 7 – python -m install pillow

Answered By: Orhan Celik

On Windows, you need to download it and install the .exe

Answered By: user285594

This worked for me on Ubuntu 16.04:

sudo apt-get install python-imaging

I found this on Wikibooks after searching for about half an hour.

Answered By: grooveplex

You will need to install Image and pillow with your python package.
Rest assured, the command line will take care of everything for you.


python -m pip install image

Answered By: Dipanshu Sehjal

you have to install Image and pillow with your python package.


python -m pip install image 

or run command prompt (in windows), then navigate to the scripts folder

cd C:Python27Scripts

then run below command

pip install image
Answered By: azdoud

if you use anaconda:

conda install pillow
Answered By: conor

instead of PIL use Pillow it works

easy_install Pillow


pip install Pillow
Answered By:

I used conda-forge to install pillow version 5, and that seemed to work for me:

conda install --channel conda-forge pillow=5

the normal conda install pillow did NOT work for me.

Answered By: Geoff Perrin

I had the same problem and i fixed it by checking what version pip (pip3 --version) is, then realizing I’m typing python<uncorrect version> instead of python<correct version>

Answered By: Ori Barmatz

I used:

pip install Pillow 

and pip installed PIL in Libsite-packages. When I moved PIL to Lib everything worked fine. I’m on Windows 10.

Answered By: cromastro

On windows 10 I managed to get there with:

cd "C:Users<your username>AppDataLocalProgramsPythonPython37-32" 
python -m pip install --upgrade pip     <-- upgrading from 10.something to 19.2.2.
pip3 uninstall pillow
pip3 uninstall PIL
pip3 install image

after which in python (python 3.7 in my case) this works fine…

import PIL
from PIL import image
Answered By: andrew pate

I used :

from pil import Image

instead of

from PIL import Image

and it worked for me fine

wish you bests

Answered By: Heydar

use pil instead of PIL

from pil import Image
Answered By: Newt

Python 3.8 on Windows 10. A combination of the answers worked for me. See below for a standalone working example. The commented out lines should be executed in the command line.

import requests
import matplotlib.pyplot as plt
# pip uninstall pillow
# pip uninstall PIL
# pip install image
from PIL import Image
url = ""
response = requests.get(url, stream=True)
img =
Answered By: Jortega
pip(3) uninstall Pillow
pip(3) uninstall PIL
pip(3) install Pillow
Answered By: Newt

I had the same issue and tried many of the solutions listed above.

I then remembered that I have multiple versions of Python installed AND I use the PyCharm IDE (which is where I was getting this error message), so the solution in my case was:

In PyCharm:

go to File>Settings>Project>Python Interpreter

click "+" (install)

locate Pillow from the list and install it

Hope this helps anyone who may be in a similar situation!

Answered By: Goob-The-Noob

Install Specific Version:

pip install Pillow

Upgrade Pillow

sudo pip3 install --upgrade Pillow

Getting Dependency Error in Window 10
Use code: easy_install instead of pip install

easy_install Pillow 

Upgrade using easy install

sudo easy_install --upgrade  Pillow

On OSX System to install Module:
Use code: brew install instead of pip install

brew install Pillow 

Without Using Pip :

 sudo apt-get install -y Pillow 

On CentOS7 or Linux Fedora:

yum -y install Pillow 

Or on Fedora try

sudo dnf install Pillow 

Command if Homebrew screws up your path on macOS:

python -m pip install Pillow 

For Python3 MacOs Homebrew screws

python3 -m pip install Pillow

Verify module from list MacOs

pip freeze | grep  Pillow

For Execute on Anaconda as your python package manager

 conda install -c anaconda Pillow 
Answered By: Shantanu Bombatkar

I found an easier solution. Use a virtual environment.

pip install Pillow
from PIL import Image

This works for me on a macOS

Answered By: Thesonter

According to the official websiteInstall Pillow, you may want to try this:

go to Terminal and run:

  • python3 -m pip install --upgrade pip

Then Run on

  • source ~/.bash_profile
Answered By: Mohamed Berrimi

The cleanest way to resolve this issue is by following below steps.

Step 1: Uninstall the PIL package.

pip uninstall PIL

Step 2: Install the Pillow using pip as shown below on windows operating systems. For other environments checkout the article No module named PIL

On Windows

python3 -m pip install --upgrade pip
python3 -m pip install --upgrade Pillow

Step 3: The most crucial class in the Python Imaging Library is the Image class, and you can import this as shown below.

from PIL import Image
im ="myimage.jpg")

If successful, this function returns an Image object. You can now use instance attributes to examine the file contents:

print(im.format, im.size, im.mode)

#Output: PPM (512, 512) RGB

I had the same issue on windows 10 and this worked for me:

pip install Pillow

Answered By: Cyebukayire

This worked for me on Ubuntu 20.04:

pip install image

And in script:

import image
Answered By: MD. Mohiuddin Ahmed

I installed Pillow through my terminal which used Python 3.11. My IDE (PyCharm) was set to Python 3.12 as an interpreter. I changed that and it worked.

Answered By: Sneezy_HD