Python 3: ImportError "No Module named Setuptools"


I’m having troubles with installing packages in Python 3.

I have always installed packages with install. But now, when I try to install the ansicolors package I get:

importerror "No Module named Setuptools"

I have no idea what to do because I didn’t have setuptools installed in the past. Still, I was able to install many packages with install without setuptools. Why should I get setuptools now?

I can’t even install setuptools because I have Python 3.3 and setuptools doesn’t support Python 3.

Why doesn’t my install command work anymore?

Asked By: user1994934



The distribute package provides a Python 3-compatible version of setuptools:

Also, use pip to install the modules. It automatically finds dependencies and installs them for you.

It works just fine for me with your package:

[~] pip --version                                                              
pip 1.2.1 from /usr/lib/python3.3/site-packages (python 3.3)
[~] sudo pip install ansicolors                                                
Downloading/unpacking ansicolors
  Downloading ansicolors-1.0.2.tar.gz
  Running egg_info for package ansicolors

Installing collected packages: ansicolors
  Running install for ansicolors

Successfully installed ansicolors
Cleaning up...
Answered By: Blender

Your file needs setuptools. Some Python packages used to use distutils for distribution, but most now use setuptools, a more complete package. Here is a question about the differences between them.

To install setuptools on Debian:

sudo apt-get install python3-setuptools

For an older version of Python (Python 2.x):

sudo apt-get install python-setuptools
Answered By: tiago

EDIT: Official setuptools dox page:

If you have Python 2 >=2.7.9 or Python 3 >=3.4 installed from, you will already have pip and setuptools, but will need to
upgrade to the latest version:

On Linux or OS X:

pip install -U pip setuptools 

On Windows:

python -m pip install -U pip setuptools

Therefore the rest of this post related to Distribute is obsolete (e.g. some links don’t work).

EDIT 2022-02-04

From Python 3.10 Distutils is deprecated and will be removed in Python 3.12 – use setuptools:

The entire distutils package is deprecated, to be removed in Python 3.12. Its functionality
for specifying package builds has already been completely replaced by
third-party packages setuptools and packaging …

Distribute (deprecated)

Distribute – is a setuptools fork which "offers Python 3 support". Installation instructions for distribute(setuptools) + pip:

curl -O
easy_install pip

Similar issue here.

UPDATE: Distribute seems to be obsolete, i.e. merged into Setuptools: Distribute is a deprecated fork of the Setuptools project. Since the Setuptools 0.7 release, Setuptools and Distribute have merged and Distribute is no longer being maintained. All ongoing effort should reference the Setuptools project and the Setuptools documentation.

You may try with instructions found on setuptools pypi page (I haven’t tested this, sorry 🙁 ):

wget -O - | python
easy_install pip
Answered By: Robert Lujo

I was doing this inside a virtualenv on Oracle Linux 6.4 using Python 2.6, so the apt-based solutions weren’t an option for me, nor were the Python 2.7 ideas. My fix was to upgrade my version of setuptools that had been installed by virtualenv:

pip install --upgrade setuptools

After that, I was able to install packages into the virtualenv.

Answered By: Dawngerpony

The PyPA recommended tool for installing and managing Python packages is pip. pip is included with Python 3.4 (PEP 453), but for older versions here’s how to install it (on Windows):


Downloading/unpacking pip
Downloading/unpacking setuptools
Installing collected packages: pip, setuptools
Successfully installed pip setuptools
Cleaning up...

>c:Python33Scriptspip.exe install pymysql
Downloading/unpacking pymysql
Installing collected packages: pymysql
Successfully installed pymysql
Cleaning up...
Answered By: Cees Timmerman

Windows 7:

I have given a complete solution here for Python Selenium WebDriver:

  1. Setup easy install (Windows – simplified)
    1. download ( from ‘’
    2. move to C:Python27
    3. open cmd prompt
    4. cd C:Python27
    5. C:Python27python.exe install
Answered By: Sathish

pip uninstall setuptools

and then:

pip install setuptools

This works for me and fixes my issue.

Answered By: gonjay

A few years ago I inherited a Python (2.7.1) project running under Django-1.2.3 and now was asked to enhance it with QR possibilities. I got the same problem and did not find pip or apt-get either. So I solved it in a totally different, but easy way.

I /bin/vi-ed the and changed the line
"from setuptools import setup"
"from distutils.core import setup"

Answered By: Roger Vermeir

The solution which worked for me was to upgrade my setuptools:

python3 -m pip install --upgrade pip setuptools wheel
Answered By: Yaakov Bressler

For others with the same issue due to a different reason: This can also happen when there’s a pyproject.toml in the same directory as the, even when setuptools is available.

Removing pyproject.toml fixed the issue for me.

Answered By: Jan Rüegg

Make sure you are running the latest version of pip

I tried to install Ansible and it failed with

ModuleNotFoundError: No module named ‘setuptools_rust’

python3-setuptools was already in place, so upgrading pip solved it.

pip3 install -U pip
Answered By: Bjarte Brandt

If pip isn’t installed, like for example if it’s coming from the Deadsnakes PPA, or a Docker environment, the best way to fix this error is by bootstrapping it by running

python -m ensurepip
Answered By: CharlesB

First step #1
You have to install setuptools

On Linux:

pip install -U pip setuptools

On Mac OS:

pip install -U pip setuptools

On Windows:

python -m pip install -U pip setuptools

Second step #2

Make sure you have made it accessible (make it available in environmental variables)

On Linux


On Mac OS

Sorry, I don’t know.

On Windows

  1. Open the Start Search, type in “env”, and choose “Edit the system environment variables”
  2. Click the “Environment Variable” button.
  3. Set the environment variables as needed. The New button adds an additional variable.
  4. Dismiss all of the dialogs by choosing “OK”. Your changes are saved!
Answered By: Rohit Nishad

When there’s a pyproject.toml in the same directory as the, it can be the cause of the issue. I renamed that file, but it didn’t solve the issue, so I restablished the original file name, and did the following change.

Under the [build-system] section, I added "setuptools" to the requires= list, and it worked.

Answered By: Lucioric2000

I ran sudo python build_ext -i and it failed with No module named setuptools.

I solved it with this command:

<i>sudo apt-get install python-setuptools</i>
Answered By: Sheldon

I ran into this problem when my pip requirements.txt file contained an editable library that was built using poetry and contained a pyproject.toml file. Following the documentation for setuptools, my solution was to add setuptools to the build-system requirements in the pyproject.toml file as follows:

requires = ["poetry-core>=1.0.0", "setuptools"]
build-backend = "poetry.core.masonry.api"
Answered By: marcusaurelius

If you still find this issue, try this:

python3 -m pip install scrapy --upgrade --force --user
Answered By: Janib Soomro

While trying to install socketIO I had the same issue. At my system (Windows 11) setupTools were there twice. At C:Program FilesPython310Libsite-packages and at C:UsersuserAppDataRoamingPythonPython310site-packages
Had to uninstall one of them.

Answered By: Niels Siebert

this is how my problem was solved => pip3 install setuptools-rust

If you want to check your list => pip3 list

i faced this problem while trying to install elastalert2

System informations

CentOS Linux release 7.9.2009 (Core)

Python 3.6.8

pip 21.3.1 from /usr/local/lib/python3.6/site-packages/pip (python 3.6)

Answered By: Musab Dogan

On macOS, if you have homebrew installed, simply run:

brew install rust
Answered By: Bartosz Petryński

I had such a problem to install pyunicorn. I wanted to install it on Google Colab. I tried installing pyunicorn directly from Github and it worked for me. For example in my case it was like this:

pip install git+
Answered By: ImanB

Working on Debian, sometime it can be because of older pip version. Therefore, update pip>

python -m pip install -U pip

Answered By: Sardar Faisal