Django DB Settings 'Improperly Configured' Error


Django (1.5) is workin’ fine for me, but when I fire up the Python interpreter (Python 3) to check some things, I get the weirdest error when I try importing – from django.contrib.auth.models import User

Traceback (most recent call last):
  File "/usr/local/lib/python3.2/dist-packages/django/conf/", line 36, in _setup
    settings_module = os.environ[ENVIRONMENT_VARIABLE]
  File "/usr/lib/python3.2/", line 450, in __getitem__
    value = self._data[self.encodekey(key)]

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.2/dist-packages/django/contrib/auth/", line 8, in <module>
    from django.db import models
  File "/usr/local/lib/python3.2/dist-packages/django/db/", line 11, in <module>
    if settings.DATABASES and DEFAULT_DB_ALIAS not in settings.DATABASES:
  File "/usr/local/lib/python3.2/dist-packages/django/conf/", line 52, in __getattr__
  File "/usr/local/lib/python3.2/dist-packages/django/conf/", line 45, in _setup

django.core.exceptions.ImproperlyConfigured: Requested setting DATABASES, 
  but settings are not configured. You must either define the environment 
  variable DJANGO_SETTINGS_MODULE or call settings.configure() 
  before accessing settings.

How could it be improperly configured, when it works fine outside the Python interpreter? In my Django settings, the DATABASES settings are:

    'default': {
        'ENGINE': 'django.db.backends.postgresql_psycopg2', # Add 'postgresql_psycopg2', 'mysql', 'sqlite3' or 'oracle'.
        'NAME': 'django_db', # Or path to database file if using sqlite3.
        # The following settings are not used with sqlite3:
        'USER': 'zamphatta',
        'PASSWORD': 'mypassword91',
        'HOST': '', # Empty for localhost through domain sockets or '' for localhost through TCP.
        'PORT': '', # Set to empty string for default.

…how is this improperly configured?

Asked By: Zamphatta



You can’t just fire up Python and check things, Django doesn’t know what project you want to work on. You have to do one of these things:

  • Use python shell
  • Use shell --settings=mysite.settings (or whatever settings module you use)
  • Set DJANGO_SETTINGS_MODULE environment variable in your OS to mysite.settings
  • (This is removed in Django 1.6) Use setup_environ in the python interpreter:

    from import setup_environ
    from mysite import settings

Naturally, the first way is the easiest.

Answered By: Pavel Anossov

In your python shell/ipython do:

from django.conf import settings

Answered By: Montaro

in my own case in django 1.10.1 running on python2.7.11, I was trying to start the server using django-admin runserver instead of runserver in my project directory.

Answered By: Dev

On Django 1.9, I tried django-admin runserver and got the same error, but when I used python runserver I got the intended result. This may solve this error for a lot of people!

Answered By: Jacob Young

In my case, I got this when trying to run Django tests through PyCharm. I think it is because PyCharm does not load the initial Django project settings, i.e. those that shell runs initially. One can add them to the start of the testing script or just run the tests using test.


  • Python 3.5 (in virtualenv)
  • PyCharm 2016.3.2 Professional
  • Django 1.10
Answered By: CoderGuy123

In 2017 with django 1.11.5 and python 3.6 (from the comment this also works with Python 2.7):

import django
import os
os.environ.setdefault("DJANGO_SETTINGS_MODULE", "mysite.settings")

The .py in which you put this code should be in mysite (the parent one)

Answered By: MagTun

For people using IntelliJ, with these settings I was able to query from the shell (on windows).

enter image description here

Answered By: Stef Van Looveren
Categories: questions Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.