ImportError: No module named Crypto.Cipher


When I try to run (Python 3.3, PyCrypto 2.6) my virtualenv keeps returning the error listed above. My import statement is just from Crypto.Cipher import AES. I looked for duplicates and you might say that there are some, but I tried the solutions (although most are not even solutions) and nothing worked.

You can see what the files are like for PyCrypto below:

Asked By: Graham Smith



I had the same problem (though on Linux). The solution was quite simple – add:

- name: pycrypto
  version: "2.6"

to my app.yaml file. Since this worked correctly in the past, I assume this is a new requirement.

Answered By: Patrick Jordan

type command:

sudo pip install pycrypto
Answered By: ruxming

I had the same problem on my Mac when installing with pip. I then removed pycrypto and installed it again with easy_install, like this:

pip uninstall pycrypto
easy_install pycrypto

also as Luke commented: If you have trouble running these commands, be sure to run them as admin (sudo)

As winklerr notes in their answer, pycrypto is no longer safe. Use pycryptodome instead, it is a drop-in replacement

Answered By: elad silver

On the mac… if you run into this.. try to see if you can import crypto instead?

If so.. the package name is the issue C vs c. To get around this.. just add these lines to the top of your script.

import crypto
import sys
sys.modules['Crypto'] = crypto

You know should be able to import paramiko successfully.

Answered By: pho

If you are using RedHat or a RedHat-based distro like Fedora or CentOS, you can install it with the following command:

sudo yum install pycrypto

In my case, I was not able to install it using pip.

Answered By: hamed

I’ve had the same problem 'ImportError: No module named Crypto.Cipher', since using GoogleAppEngineLauncher (version > 1.8.X) with GAE Boilerplate on OSX 10.8.5 (Mountain Lion). In Google App Engine SDK with python 2.7 runtime, pyCrypto 2.6 is the suggested version.
The solution that worked for me was…

1) Download pycrypto2.6 source extract it somewhere(~/Downloads/pycrypto26)

e.g., git clone

2) cd (cd ~/Downloads/pycrypto26) then

3) Execute the following terminal command inside the previous folder in order to install pyCrypto 2.6 manually in GAE folder.

sudo python install --install-lib /Applications/
Answered By: Lazaros Dinakis

For Windows 7:

I got through this error “Module error Crypo.Cipher import AES”

To install Pycrypto in Windows,

Try this in Command Prompt,

Set path=C:Python27Scripts (i.e path where easy_install is located)

Then execute the following,

easy_install pycrypto

For Ubuntu:

Try this,

Download Pycrypto from “

Then change your current path to downloaded path using your terminal:

Eg: [email protected]:~/pycrypto-2.6.1#

Then execute the following using the terminal:

python install

It’s worked for me. Hope works for all..

Answered By: JayaPrakash

I solve this problem by change the first letter case to upper.
Make sure ”from Crypto.Cipher import AES” not ”from crypto.Cipher import AES”.

Answered By: Zesheng LI

I found the solution. Issue is probably in case sensitivity (on Windows).

Just change the name of the folder:


To this:


This is how folder was named after installation of pycrypto:
enter image description here

I’ve changed it to:
enter image description here

And now the following code works fine:
enter image description here

Answered By: damian1baran

I ran into this on Mac as well, and it seems to be related to having an unfortunately similarly named “crypto” module (not sure what that is for) installed alongside of pycrypto via pip.

The fix seems to be removing both crypto and pycrypto with pip:

sudo pip uninstall crypto
sudo pip uninstall pycrypto

and reinstalling pycrypto:

sudo pip install pycrypto

Now it works as expected when I do something like:

from Crypto.Cipher import AES
Answered By: user42935

This problem can be fixed by installing the C++ compiler (python27 or python26). Download it from Microsoft and re-run the command : pip install pycrypto to run the gui web access when you kill the process of easy_install.exe.

Answered By: user8094201

Try with pip3:

sudo pip3 install pycrypto
Answered By: Arthur Ronconi

Uninstalling crypto and pycrypto works on me. Then install only pycrypto:

pip uninstall crypto 
pip uninstall pycrypto 
pip install pycrypto
Answered By: tthreetorch

It could be a problem of loading python modules installed via pip. Refer to this answer Can't load Python modules installed via pip from site-packages directory and try something like

python -m pip install pycrypto
Answered By: user666N

For CentOS 7.4 I first installed pip and then pycrypto using pip:

> sudo yum -y install python-pip 
> sudo python -m pip install pycrypto
Answered By: stuhpa

Worked for me (Ubuntu 17.10)

Removing venv and creating it again with python v3.6

pip3 install PyJWT
sudo apt-get install build-essential libgmp3-dev python3-dev
pip3 install cryptography
pip3 install pycryptodome
pip3 install pycryptodomex

Pycrypto is deprecated, had problems with it, used Pycryptodome

Answered By: applekate

To date, I’m having same issue when importing from Crypto.Cipher import AES even when I’ve installed/reinstalled pycrypto a few times. End up it’s because pip defaulted to python3.

~ pip --version
pip 18.0 from /usr/local/lib/python3.7/site-packages/pip (python 3.7)

installing pycrypto with pip2 should solve this issue.

Answered By: Ryan

Maybe you should add this to your requirements.txt file:


Then install all dependencies using:

pip install -r requirements.txt

This should eliminate the error report. It worked for me!

Answered By: imissyou

If you are in a Mac OS, rename the lib folder:


To this:

Answered By: Jack

I’m with Python 3.7. The issue remains after I try to install crypto.

And pycrypto just fails in my case. So in the end my build passed by using the following package:

pip install pycryptodome
Answered By: Quansheng Li

WARNING: Don’t use crypto or pycrypto anymore!

As you can read on this page, the usage of pycrypto is not safe anymore:

Pycrypto is vulnerable to a heap-based buffer overflow in the ALGnew function in block_templace.c. It allows remote attackers to execute arbitrary code in the python application. It was assigned the CVE-2013-7459 number.

Pycrypto didn’t release any fix to that vulnerability and no commit was made to the project since Jun 20, 2014.

Update 2021-01-18

The CVE is fixed now (thanks @SumitBadsara for pointing it out!). You can find the current status of the open security tickets for each package at the Debian security tracker:

Use Python3’s pycryptodome instead!

Make sure to uninstall all versions of crypto and pycrypto first, then install pycryptodome:

pip3 uninstall crypto 
pip3 uninstall pycrypto 
pip3 install pycryptodome

All of these three packages get installed to the same folder, named Crypto. Installing different packages under the same folder name can be a common source for errors!

For more information, see

Best practice: virtual environments

In order to avoid problems with pip packages in different versions or packages that install under the same folder (i.e. pycrypto and pycryptodome) you can make use of a so called virtual environment. There, the installed pip packages can be managed for every single project individually.

To install a virtual environment and setup everything, use the following commands:

# install python3 and pip3
sudo apt update
sudo apt upgrade
sudo apt install python3
sudo apt install python3-pip

# install virtualenv
pip3 install virtualenv

# install and create a virtual environment in your target folder
mkdir target_folder
cd target_folder
python3 -m virtualenv .

# now activate your venv and install pycryptodome
source bin/activate
pip3 install pycryptodome

# check if everything worked: 
# start the interactive python console and import the Crypto module
# when there is no import error then it worked
>>> from Crypto.Cipher import AES
>>> exit()

# don't forget to deactivate your venv again

For more information, see

Answered By: winklerrr

Well this might appear weird but after installing pycrypto or pycryptodome , we need to update the directory name crypto to Crypto in lib/site-packages


Answered By: Abhishake Gupta

This worked for me

pip install pycryptodome==3.4.3
Answered By: Saad Mirza

If you are using this module with Python3 and having trouble with import.
try this.

pip uninstall crypto
pip uninstall pycryptodome
pip install pycryptodome

Good Luck!

Answered By: Ashok Shah

I had simular problem and fixed it with the next command

sudo pip3 install py
Answered By: Gerry

One more reminder if you still encounter this issue after uninstall crypto and pycrypto like this

pip3 uninstall crypto
pip3 uninstall pycrypto

Just check if there is a directory named crypto(lower case) in your site-packages under
/usr/local/lib/python3.9/site-packages, make sure the python version your used and the right site-packages path, then remove the crypto directory, the try to install again.

Answered By: xfangbo

I was facing same problem in django. I was getting error while importing:

from Crypto.Cipher import AES

Then I installed pycryptodome with:

pip install pycryptodome

Finally, I changed the code to :

from crypto.Cipher import AES
Answered By: Harry John

Even after installing Crypto I was getting below error:

Traceback (most recent call last):
  File "", line 19, in <module>
    from Crypto.Cipher import AES
ModuleNotFoundError: No module named 'Crypto'

Then in this post I found the command that solved the issue.

pip install pycryptodome
Answered By: Darshan R

Not sure if this going to help anyone but I had the exact same issue trying to run: samrdump on Kali Linux.

after a lot of work (I checked similar issues on the repo here).
I discovered that typing python3 instead of python (as python uses python2) solved the issue:

sudo python3
sudo python3
Answered By: ShifraSec

My solution seems to be strange but I used to run my file like this,

Than I run it like that and it worked

Answered By: Houari Belgaid

Simply delete your existing folder of pycrypto/pycryptodome-3.11.0 located at:


Then run:

pip install pycryptodome
Answered By: abhijeetThakur

Run the following codes in your terminal screen

pip uninstall crypto
pip uninstall pycryptodome
pip install pycryptodome
Answered By: isa

this works for me:

pip install pycryptodomex


from Cryptodome.Cipher import AES
Answered By: Jyhonn