pip installs packages successfully, but executables not found from command line


I am working on mac OS X Yosemite, version 10.10.3.

I installed python2.7 and pip using macport as done in

I can successfully install packages and import them inside my python environment and python scripts. However any executable associated with a package that can be called from the command line in the terminal are not found.

Does anyone know what might be wrong? (More details below)

For example while installing a package called “rosdep” as instructed in http://wiki.ros.org/jade/Installation/Source

I can run: sudo pip install -U rosdep
which installs without errors and corresponding files are located in /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages

However if I try to run : sudo rosdep init,
it gives an error : "sudo: rosdep: command not found"

This is not a package specific error. I get this for any package installed using pip on my computer. I even tried adding


to my $PATH.
But the executables are not found on the command line, even though the packages work perfectly from within python.

Asked By: Sanket_Diwale



check your $PATH

tox has a command line mode:

audrey:tests jluc$ pip list | grep tox
tox (2.3.1)

where is it?

(edit: the 2.7 stuff doesn’t matter much here, sub in any 3.x and pip’s behaving pretty much the same way)

audrey:tests jluc$ which tox

and what’s in my $PATH?

audrey:tests jluc$ echo $PATH

Notice the /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin? That’s what allows finding my pip-installed stuff

Now, to see where things are from Python, try doing this (substitute rosdep for tox).

>>> import tox
>>> tox.__file__

that prints out:


Now, cd to the directory right above lib in the above. Do you see a bin directory? Do you see rosdep in that bin? If so try adding the bin to your $PATH.

audrey:2.7 jluc$ cd /opt/local/Library/Frameworks/Python.framework/Versions/2.7
audrey:2.7 jluc$ ls -1


Answered By: JL Peyret

On macOS with the default python installation you need to add /Users/<you>/Library/Python/2.7/bin/ to your $PATH.

Add this to your .bash_profile:

export PATH="/Users/<you>/Library/Python/2.7/bin:$PATH"

That’s where pip installs the executables.

Tip: For non-default python version which python to find the location of your python installation and replace that portion in the path above. (Thanks for the hint Sanket_Diwale)

Answered By: joh-mue

If you’re installing using --user (e.g. pip3.6 install --user tmuxp), it is possible to get the platform-specific user install directory from Python itself using the site module. For example, on macOS:

$ python2.7 -m site --user-base

By appending /bin to this, we now have the path where package executables will be installed. We can dynamically populate the PATH in your shell’s rc file based on the output; I’m using bash, but with any luck this is portable:

# Add Python bin directories to path
python3.6 -m site &> /dev/null && PATH="$PATH:`python3.6 -m site --user-base`/bin"
python2.7 -m site &> /dev/null && PATH="$PATH:`python2.7 -m site --user-base`/bin"

I use the precise Python versions to reduce the chance of the executables just “disappearing” when Python upgrades a minor version, e.g. from 3.5 to 3.6. They’ll disappear because, as can be seen above, the user installation path may include the Python version. So while python3 could point to 3.5 or 3.6, python3.6 will always point to 3.6. This needs to be kept in mind when installing further packages, e.g. use pip3.6 over pip3.

If you don’t mind the idea of packages disappearing, you can use python2 and python3 instead:

# Add Python bin directories to path
# Note: When Python is upgraded, packages may need to be re-installed
#       or Python versions managed.
python3 -m site &> /dev/null && PATH="$PATH:`python3 -m site --user-base`/bin"
python2 -m site &> /dev/null && PATH="$PATH:`python2 -m site --user-base`/bin"
Answered By: Alex Palmer

I stumbled upon this question because I created, successfully built and published a PyPI Package, but couldn’t execute it after installation. The $PATHvariable was correctly set.

In my case the problem was that I hadn’t set the entry_pointin the setup.py file:

entry_points = {'console_scripts':

Answered By: Git.Coach

On Windows, you need to add the path %USERPROFILE%AppDataRoamingPythonScripts to your path.

Answered By: Jared Beach

In addition to adding python’s bin directory to $PATH variable, I also had to change the owner of that directory, to make it work. No idea why I wasn’t the owner already.

chown -R ~/Library/Python/
Answered By: d4Rk

I know the question asks about macOS, but here is a solution for Linux users who arrive here via Google.

I was having the issue described in this question, having installed the pdfx package via pip.

When I ran it however, nothing…

pip list | grep pdfx
pdfx (1.3.0)


which pdfx
pdfx not found

The problem on Linux is that pip install ... drops scripts into ~/.local/bin and this is not on the default Debian/Ubuntu $PATH.

Here’s a GitHub issue going into more detail: https://github.com/pypa/pip/issues/3813

To fix, just add ~/.local/bin to your $PATH, for example by adding the following line to your .bashrc file:

export PATH="$HOME/.local/bin:$PATH"

After that, restart your shell and things should work as expected.

Answered By: James Hibbard


Based on other answers, for linux and mac you can run the following:

echo "export PATH="`python3 -m site --user-base`/bin:$PATH"" >> ~/.bashrc
source ~/.bashrc

instead of python3 you can use any other link to python version: python, python2.7, python3.6, python3.9, etc.

instead of .bashrc, choose the rc file from your favourite shell.


In order to know where the user packages are installed in the current OS (win, mac, linux), we run:

python3 -m site --user-base

We know that the scripts go to the bin/ folder where the packages are installed.

So we concatenate the paths:

echo `python3 -m site --user-base`/bin

Then we export that to an environment variable.

export PATH="`python3 -m site --user-base`/bin:$PATH"

Finally, in order to avoid repeating the export command we add it to our .bashrc file and we run source to run the new changes, giving us the suggested solution mentioned at the beginning.

Answered By: Willemoes

When you install Python or Python3 using MacOS installer (downloaded from Python website) – it adds an exporter to your ~/.profile script. All you need to do is just source it. Restarting all the terminals should also do the trick.

WARNING – I believe it’s better to just use pip3 with Python3 – for future benefits.

If you already have Python3 installed, the following steps work for me on macOS Mojave:

  1. Install ansible first using sudosudo -H pip3 install ansible

  2. you create a symlink to the Python’s bin path

sudo ln -s /Library/Frameworks/Python.framework/Versions/Current/bin /Library/Frameworks/Python.framework/current_python_bin

and staple it to .profile

export PATH=$PATH:/Library/Frameworks/Python.framework/current_python_bin

  1. run source ~/.profile and restart all terminal shells.

  2. Type ansible --version

Answered By: ha9u63ar

The Installing Packages tutorial on python.org describes how to locate the binary directory:

On Windows

You can find the user base binary directory by running
python -m site --user-site and replacing site-packages with Scripts.
For example, this could return
C:UsersUsernameAppDataRoamingPython36site-packages so you
would need to set your PATH to include

On Linux and macOS

On Linux and macOS you can find the user base binary directory by
running python -m site --user-base and adding bin to the end. For
example, this will typically print ~/.local (with ~ expanded to the
absolute path to your home directory) so you’ll need to add
~/.local/bin to your PATH.

Answered By: Narendra Rana

Windows and Python 3.9 from MS Store

I have a different path with python -m site --user-base and python -m site – yes, the second command without --user-base to get all sites – as the other answers here state:

C:Users<your User>AppDataLocalPackagesPythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0LocalCachelocal-packagesPython39site-packages

Why is my path different

Because I installed python from MS Store


Put the above path in your path and replace site-packages with scripts

Answered By: Timo

had the same issue with macOS Monterey. I had to modify my .bash_profile file and add the following entry

export PATH="~/Library/Python/3.8/bin:$PATH"

The default python version on macOS Monterey is 3.8, but you will have to double check your python version to make sure you’re using the correct one

Answered By: Diego Velez

I solve the problem!

  1. Use pip3 instead pip.
  2. pip3 install foobaz
  3. vim ~/.zshrc and add:
export PATH="/Users/your_name/Library/Python/3.8/bin:$PATH"
  1. source ~/.zshrc

Now MacOS has shifted the default terminal from bash to zsh. Therefore, you have to source zshrc but not bashrc or bash_profile.

  1. foobaz -v
Answered By: Pandy
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.