Install Python package: "Package missing in current win-64 channels"


I want to install GSEApy on Anaconda (I use 64bit Windows 10).

But I get this error:

C:Windowssystem32>conda install gseapy

Using Anaconda Cloud api site https://
Fetching package metadata ...........
Solving package specifications: .
Error: Package missing in current win-64 channels:
  - gseapy

You can search for packages on with
anaconda search -t conda gseapy

How can I solve this?

Asked By: Benni



You need to use a channel that has a win-64 version. Use:

conda install -c bioninja gseapy

The option -c or --channel allows to specify a channel.
You can also add a channel permanently via:

conda config --add channels bioninja

This creates a file .condarc in your home directory (on Windows C:Users<username>):

  - bioninja
  - defaults

You can modify this file manually. The order of the channels determines
their precedence.

Note: Files with a leading . might not be displayed
by certain file browsers. You might need to change settings to display these
files accordingly.

You can find out if a package exits for your platform by searching on Anaconda. Just type gseapy in the search field and you should see the available packages. The column “Platforms” shows if a “win-64” version exists.

enter image description here

Answered By: Mike Müller

Now you could install lastest gseapy through bioconda, too

conda install -c bioconda gseapy 
Answered By: maxima

Maybe it need you to specify a detalied version,so you can just find a version support your environment in Anaconda Clound,just a line of command like “conda install -c dhirschfeld protobuf=3.0.0a3.post418+g0cb84ee “,I select this and it works.

Answered By: Dartagnan

Check the latest version of Keras from the Anaconda Cloud website

Use command:

conda install -c conda-forge keras=<version>
Answered By: Prakhar Agarwal
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.