"filename.whl is not a supported wheel on this platform"


I saw the same question, but it didn’t work for me.

pip install PyOpenGL.3.1.1-cp34-cp34m-win_amd64.whl

I also have the same problem for NumPy:

pip install numpy-1.11.1+mkl-cp34-cp34m-win_amd64.whl

Then I get:

numpy-1.11.1+mkl-cp34-cp34m-win_amd64.whl is not a supported wheel on
this platform. Storing debug log for failure in

I’m using 64-bit and Python 3.4.0. What is wrong?

Asked By: teoman



You’ll probably have to rename your .whl file like numpy-1.11.1+mkl-cp34-none-win_amd64.whl before installing. Your pip has a finite number of tags it recognizes in wheel filenames.

See this answer for more on this: Cannot install numpy from wheel format

Answered By: konoufo

Try updating pip first before you rename pip install --upgrade pip

Answered By: DSchmidt

There are several things to consider

Python versions should match, OS should be 64 bit and python should also be 64 bit.

And as in your case both of these conditions are met, you have to make sure that pip is able to handle all the fields in wheel file name.

For example in my case my pip was not handling “cp35m”

To ensure, in python shell

import pip

Then type


you should be able to see all the fields your pip command can handle. If any one is missing try updating Pip first.

However in my case even updating was giving error. So I uninstalled python 3.5.1 and installed python 3.5.2, and that worked for me.

Answered By: user3046442

Things to check for:

  1. Even though I my system is 64 I had 32 python installed. You can check this by opening your IDLE.
  2. I had python 2 and 3 installed so updating pip was updating the wrong python for me. And of course I just wasn’t trying to install the right kind of package because it was the wrong python version in the path.
  3. If you are still having some problems like me where doing pip2 or pip3 fixes didn’t seem to work, I did a quick fix. My pip only had python 3 in its path, so I went to systems>advanced system settings>environment variables and then added “C:Python27Scripts” to the PATH variable. This solved my issues.
Answered By: Christina Wang

Be sure to have Python 64 bit install.
You can download it here and the 64bit version is at the bottom of the page: https://www.python.org/downloads/release/python-370/

Answered By: user9269553
  1. Check the supported tags for wheel version for your system(platform).
  2. To check supported tag run the following command pip debug --verbose
  3. When you run the command, you will get many lists, along with supported tags, download compatible wheel file from supported tags.
  4. install wheel file using this command pip install pycurl-

Supported tags portion looks like:

enter image description here

Answered By: Sadekujjaman

First check which version of the interpreter, 32-bit or 64-bit. Type python and you will get it. Mine is 64 bit.

Next, check if your wheel file is for 64 bit or 32 bit. Compare it with your Python bitness to see if it is the same or not.

If there is still an error coming, check your file location in CMD and compare it with where you have saved your file.

Save the file in the cmd location, for example, *C:Users*, and you get the result successfully installed.

Answered By: Alex Joseph

This is late, but I ran into this error recently. At one point I created a folder with several prerequisite .whl files and added "prereq – 1 – ", "prereq – 2 – ", etc. to the beginnings of the filenames to help others/myself in the future know which order to install them in (I work in an offline environment).

I would get the "filename.whl is not a supported wheel on this platform" error when trying to py -m pip install "filename.whl" --no-index. When I removed the filename "prefix" that I added, it worked.

Just wanted to throw this out there in case anyone else runs into this issue after editing the name of a .whl file.

Answered By: Alex
Categories: questions Tags: , , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.