'Conda' is not recognized as internal or external command


I installed Anaconda3 4.4.0 (32 bit) on my Windows 7 Professional machine and imported NumPy and Pandas on Jupyter notebook so I assume Python was installed correctly. But when I type conda list and conda --version in command prompt, it says conda is not recognized as internal or external command.

I have set environment variable for Anaconda3; Variable Name: Path, Variable Value: C:Usersdipanwita.neogyAnaconda3

How do I make it work?

Asked By: Kshitiz



I found the solution.
Variable value should be C:Usersdipanwita.neogyAnaconda3Scripts

Answered By: Kshitiz

Just to be clear, you need to go to the controlpanelSystemAdvanced system settingsEnvironment VariablesPath,
then hit edit and add:


to the end and restart the cmd line

Answered By: Carl

Although you were offered a good solution by others I think it is helpful to point out what is really happening. As per the Anaconda 4.4 changelog, https://docs.anaconda.com/anaconda/reference/release-notes/#what-s-new-in-anaconda-4-4:

On Windows, the PATH environment variable is no longer changed by default, as this can cause trouble with other software. The recommended approach is to instead use Anaconda Navigator or the Anaconda Command Prompt (located in the Start Menu under “Anaconda”) when you wish to use Anaconda software.

(Note: recent Win 10 does not assume you have privileges to install or update. If the command fails, right-click on the Anaconda Command Prompt, choose “More”, chose “Run as administrator”)

This is a change from previous installations. It is suggested to use Navigator or the Anaconda Prompt although you can always add it to your PATH as well. During the install the box to add Anaconda to the PATH is now unchecked but you can select it.

Answered By: John Morrison

When you install anaconda on windows now, it doesn’t automatically add Python or Conda to your path.

While during the installation process you can check this box, you can also add python and/or python to your path manually (as you can see below the image)

enter image description here

If you don’t know where your conda and/or python is, you type the following commands into your anaconda prompt

where python
where conda

Next, you can add Python and Conda to your path by using the setx command in your command prompt (replace C:UsersmgalarnykAnaconda2 with the results you got when running where python and where conda).

SETX PATH "%PATH%;C:UsersmgalarnykAnaconda2Scripts;C:UsersmgalarnykAnaconda2"

Next close that command prompt and open a new one. Congrats you can now use conda and python

Source: https://medium.com/@GalarnykMichael/install-python-on-windows-anaconda-c63c7c3d1444

If you have a newer version of the Anaconda Navigator, open the Anaconda Prompt program that came in the install. Type all the usual conda update/conda install commands there.

I think the answers above explain this, but I could have used a very simple instruction like this. Perhaps it will help others.

Answered By: MokeEire

If you don’t want to add Anaconda to env. path and you are using Windows try this:

  • Open cmd;
  • Type path to your folder instalation. It’s something like:
    C:Usersyour_home folderAnaconda3Scripts
  • Test Anaconda, for exemple type conda –version.
  • Update Anaconda: conda update conda or conda update –all or conda update anaconda.

Update Spyder:

  • conda update qt pyqt
  • conda update spyder
Answered By: Dragos Alexe

I was faced with the same issue in windows 10, Updating the environment variable following steps, it’s working fine.

I know It is a lengthy answer for the simple environment setups, I thought it’s may be useful for the new window 10 users.

1) Open Anaconda Prompt:

enter image description here

2) Check Conda Installed Location.

where conda

enter image description here

3) Open Advanced System Settings

enter image description here

4) Click on Environment Variables

enter image description here

5) Edit Path

enter image description here

6) Add New Path




enter image description here

7) Open Command Prompt and Check Versions

8) After 7th step type
conda install anaconda-navigator in cmd then press y

enter image description here

Go To anaconda prompt(type “anaconda” in search box in your laptop). type following commands

where conda

add that location to your environment path variables. Close the cmd and open it again

Answered By: Pallamolla Sai

I had this problem in windows. Most of the answers are not as recommended by anaconda, you should not add the path to the environment variables as it can break other things. Instead you should use anaconda prompt as mentioned in the top answer.

However, this may also break. In this case right click on the shortcut, go to shortcut tab, and the target value should read something like:

%windir%System32cmd.exe "/K" C:UsersmyUserAnaconda3Scriptsactivate.bat C:UsersmyUserAnaconda3
Answered By: anishtain4

I have Windows 10 64 bit, this worked for me,
This solution can work for both (Anaconda/MiniConda) distributions.

  1. First of all try to uninstall anaconda/miniconda which is causing problem.
  2. After that delete ‘.anaconda’ and ‘.conda’ folders from ‘C:Users’
  3. If you have any antivirus software installed then try to exclude all the folders,subfolders inside ‘C:ProgramDataAnaconda3’ from

    • Behaviour detection.
    • Virus detection.
    • DNA scan.
    • Suspicious files scan.
    • Any other virus protection mode.

    *(Note: ‘C:ProgramDataAnaconda3’ this folder is default installation folder, you can change it just replace your excluded path at installation destination prompt while installing Anaconda)*

  4. Now install Anaconda with admin privileges.
    • Set the installation path as ‘C:ProgramDataAnaconda3’ or you can specify your custom path just remember it should not contain any white space and it should be excluded from virus detection.
    • At Advanced Installation Options you can check “Add Anaconda to my PATH environment variable(optional)” and “Register Anaconda as my default Python 3.6”
    • Install it with further default settings. Click on finish after done.
    • Restart your computer.

Now open Command prompt or Anaconda prompt and check installation using following command

conda list

If you get any package list then the anaconda/miniconda is successfully installed.

Answered By: k33da_the_bug

In addition to adding C:UsersyourusernameAnaconda3 and C:UsersyourusernameAnaconda3Scripts, as recommended by Raja (above), also add C:UsersyourusernameAnaconda3Librarybin to your path variable. This will prevent an SSL error that is bound to happen if you’re performing this on a fresh install of Anaconda.

Answered By: Thomas Matthew

This problem arose for me when I installed Anaconda multiple times. I was careful to do an uninstall but there are some things that the uninstall process doesn’t undo.

In my case, I needed to remove a file Microsoft.PowerShell_profile.ps1 from ~DocumentsWindowsPowerShell. I identified that this file was the culprit by opening it in a text editor. I saw that it referenced the old installation location C:Anaconda3.

Answered By: Aaron

I have just launched anaconda-navigator and run the conda commands from there.

Answered By: Ganesh Kanna

if you use chocolatey, conda is in C:toolsAnaconda3Scripts

Answered By: dkocich

For conda --version greater than 4.6, from the base of your Anaconda promt, run

conda update conda
conda init

This will update your conda root environment and setup the stuff you need to run it on both cwd and powershell.

After this, you can start any terminal and it will be conda ready.

Answered By: zeeshan khan

For those who didn’t check "Add Anaconda to my PATH environment variable". In Windows 10 it looks like that:

enter image description here

5 paths:

Answered By: shtosh