after pip successful installed: ModuleNotFoundError


I am trying to install the SimPy module so that I can use it in IDLE. However, everytime I try to import in IDLE, I got an error. I already tried reinstalling Python and Pip and tried to modify the location of the apps. SimPy can be found in the directory of Python 2.7. I’m using python 3.6.1.

After I correctly installed simpy in the terminal:

pip install simpy
Requirement already satisfied: simpy in /Library/Python/2.7/site-packages

When I put into IDLE:

Import Simpy

I got the error:

    Traceback (most recent call last):
  File "<pyshell#3>", line 1, in <module>
    import simpy
ModuleNotFoundError: No module named 'simpy'

How can I solve this?

Asked By: Robert



Since you are using python 3.6.1, you may need to specify the type of python you want to install simpy for. Try running pip3 install simpy to install the simpy module to your python3 library.

Answered By: cosinepenguin

I had same problem (on Windows) and the root cause in my case was ANTIVIRUS software! It has “Auto-Containment” feature, that wraps running process with some kind of a virtual machine.
Symptoms are the same: pip install <module> works fine in one cmd line window and import <module> fails when executed from another process.

Answered By: Dima G

Wherever you’re running your code, try this

import sys


It might be possible that you’re running python in one environment and the module is installed in another environment.

Answered By: alok.m

What worked for me is that adding the module location to the sys.path

import sys
sys.path.insert(0, r"/path/to/your/module")
Answered By: Argun SAYIN

When this happened to me (on macOS), the problem turned out to be that the python installation I specified at the top of my was not the same python installation that conda/pip were using on the command line.

To get the command line and my script to match up, I changed the header in my to just use:


Then when I ran ./ on the command line, everything finally worked.

Answered By: Robin Stewart

This command works for me for the same issue.

python -m pip install “your library” 
Answered By: Rehan Ahmed

I wrote a package by myself and I thought the could be ignored, then I encountered this issue. when I added an empty to my package, this issue was fixed.

Answered By: jianjunwu

Do not have a file called in the current working directory, as python will try to load this file instead of the module that you want.

This may cause the problem described in the title of this question.

Answered By: Bálint Sass
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.