Conda command is not recognized on Windows 10


I installed Anaconda 4.4.0 (Python 3.6 version) on Windows 10 by following the instructions here: However, when I open the Command prompt window and try to write

conda list

I get the

‘conda’ command is not recognized…


I tried to run

set PATH=%PATH%;C:UsersAlexAnaconda3

but it didn’t help. I also read that I might need to edit my .bashrc file, but I don’t know how to access this file, and how I should edit it.

Asked By: alex



In Windows, you will have to set the path to the location where you installed Anaconda3 to.

For me, I installed anaconda3 into C:Anaconda3. Therefore you need to add C:Anaconda3 as well as C:Anaconda3Scripts to your path variable, e.g. set PATH=%PATH%;C:Anaconda3;C:Anaconda3Scripts.

You can do this via powershell (see above, ), or hit the windows key → enter environment → choose from settingsedit environment variables for your account → select Path variable → EditNew.

To test it, open a new dos shell, and you should be able to use conda commands now. E.g., try conda --version.

Answered By: mjoppich

Even I got the same problem when I’ve first installed Anaconda. It said ‘conda’ command not found.

So I’ve just setup two values[added two new paths of Anaconda] system environment variables in the PATH variable which are:
C:UsersmshasAnaconda2 &

Lot of people forgot to add the second variable which is “Scripts” just add that then ‘conda’ command works.

Answered By: Shashank Kumar

When you install anaconda on windows now, it doesn’t automatically add Python or Conda.

If you don’t know where your conda and/or python is, you type the following commands into your anaconda prompt

enter image description here

Next, you can add Python and Conda to your path by using the setx command in your command prompt.
enter image description here

Next close that command prompt and open a new one. Congrats you can now use conda and python


You need to add the python.exe in C://…/Anaconda3 installation file as well as C://…/Anaconda3/Scripts to PATH.

First go to your installation directory, in my case it is installed in C://Users/user/Anaconda3 and shift+right click and press “Open command window here” or it might be “Open powershell here”, if it is powershell, just write cmd and hit enter to run command window. Then run the following command setx PATH %cd%

Then go to C://Users/user/Anaconda3/Scripts and open the command window there as above, then run the same command “setx PATH %cd%”

Answered By: user3578953

I had also faced the same problem just an hour back. I was trying to install QuTip Quantum Toolbox in Python
Unfortunately, I didn’t stumble onto this page in time.
Say you have downloaded Anaconda installer and run it until the end.
Naively, I opened the command prompt in windows 10 and proceded to type the following commands as given in the qutip installation docs.

conda create -n qutip-env

conda config –append channels conda-forge

conda install qutip

But as soon as I typed the first line I got the following response

conda is not recognized as an internal or external command, operable program or batch file

error messsage

I went ahead and tried some other things as seen in this figures
error message
Finally after going through a number conda websites, I understood how one fixes this problem.
Type Anaconda prompt in the search bar at the bottom like this (same place where you hail Cortana)
Anaconda prompt

Once you are here all the conda commands will work as usual

Answered By: Avinash Shetty

If you want to use Anaconda in regular cmd on windows you need to add several paths to your Path env variable.

Those paths are (instead of Anaconda3 the folder may be Anaconda2 depending on the Anaconda version on your PC):

Answered By: Gabriel P.

If you have installed Visual studio 2017 (profressional)

The install location:


If you do not want the hassle of putting this in your path environment variable on windows and restarting you can run it by simply:

C:>"C:ProgramDataAnaconda3Scriptsconda.exe" update qt pyqt
Answered By: navarq

case #1
You should set 3 path:


It will solve problem:

C:WINDOWSsystem32>conda update conda
Solving environment: failed

CondaHTTPError: HTTP 000 CONNECTION FAILED for url <>
Elapsed: -

case #2
Also you can use Anaconda Promd (for Win10) instead CLI (cmd.exe)

The newest version of the Anaconda installer for Windows will also install a windows launcher for “Anaconda Prompt” and “Anaconda Powershell Prompt”. If you use one of those instead of the regular windows cmd shell, the conda command, python etc. should be available by default in this shell.

enter image description here

Answered By: Håken Lid

To prevent having further issues with SSL you should add all those to Path :

 SETX PATH "%PATH%;C:<path>Anaconda3;C:<path>Anaconda3Scripts;C:<path>Anaconda3Librarybin"

Requests (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.") Error in PyCharm requesting website

Answered By: deltascience

Things have been changed after conda 4.6.

Programs "Anaconda Prompt" and "Anaconda Powershell" expose the command conda for you automatically. Find them in your startup menu.

If you don’t wanna use the prompts above and try to make conda available in a standard cmd.exe or a standard Powershell. Read the following content.

Expose conda in Every Shell

The purpose of the following content is to make command conda available both in cmd.exe and Powershell on Windows.

If you have already checked "Add Anaconda to my PATH environment variable" during Anaconda installation, skip step 1.

Anaconda installation options on Windows

  1. If Anaconda is installed for the current use only, add %USERPROFILE%Anaconda3condabin (I mean condabin, not Scripts) into the environment variable PATH (the user one). If Anaconda is installed for all users on your machine, add C:ProgramDataAnaconda3condabin into PATH.

    How do I set system environment variables on Windows?

  2. Open a new Powershell, run the following command once to initialize conda.

    conda init

These steps make sure the conda command is exposed into your cmd.exe and Powershell.

Extended Reading: conda init from Conda 4.6

Caveat: Add the new pathtoanaconda3condabin but not pathtoanaconda3Scripts into your PATH. This is a big change introduced in conda 4.6.

Activation script initialization fron conda 4.6 release log

Conda 4.6 adds extensive initialization support so that more shells than ever before can use the new conda activate command. For more information, read the output from conda init –help We’re especially excited about this new way of working, because removing the need to modify PATH makes Conda much less disruptive to other software on your system.

In the old days, pathtoanaconda3Scripts is the one to be put into your PATH. It exposes command conda and the default Python from "base" environment at the same time.

After conda 4.6, conda related commands are separated into condabin. This makes it possible to expose ONLY command conda without activating the Python from "base" environment.


Answered By: Simba

According to the official documentation, for Windows users there are two environment variable PATHs which can be updated, depending on how your Miniconda/Anaconda distribution has been installed — one is the SYSTEM PATH, the other is the USER PATH:

Basically it says the following: If like the official recommendation you have installed conda for yourself on the user level only, you can add a path similar to C:Users<user-name>miniconda3Scripts to the user variables.

Please remember to change to Anaconda if you are not using miniconda and update the to your system username in order for this to work.

However, if you have a system level install for all users on the same machine, you should add the path c:miniconda3Scripts to the system variables.

Also, please run conda init in your PowerShell to have conda working on your PowerShell. If there is a Python version already installed on your PC, you can disable "app execution aliases" in Settings (under "Manage app execution aliases") for this to use only the Python ones on the command line to avoid conflict.

Answered By: Kris Stern