ModuleNotFoundError: No module named 'pandas'


I’m following a practical machine learning tutorial and I am already stuck on the second video.

 import pandas as pd
 import Quandl

 df = Quandl.get('WIKI/GOOGL')

When I run the same code as the man in the video, all I get is

ModuleNotFoundError: No module named ‘pandas’

I’m on Windows 10 using Visual Studio 2017 and I already did pip install pandas. I have python 3.6.1 installed.

  • pip 9.0.1 from C:Program FilesAnaconda3libsite-packages (python 3.6).
  • pandas (0.19.2).
  • Python 3.6.0 :: Anaconda 4.3.0 (64-bit)
Asked By: Erick Eaton



I think you can use conda update pandas and it should get the most current version for you dist.
Or, pip install –update pandas
Also in python 3 quandl will be lowercase.
Edit.. pandas in on ver. 0.21.0 currently.

Answered By: Jasong

To make sure that you’re using the same pip as your python, execute the pip with whole path from python directory i.e.

C:Program FilesAnaconda3libsite-packages (python 3.6)pip install pandas  

This will install the pandas in the same directory

Or C:Python365pip install pandas

Or C:Python27pip install pandas

Whichever Python you wand to use and install the pandas

If you want to use a specific version of Python in Windows cmd, just add the path of that Python in System Variables.

Answered By: v_kumar

I had a similar problem which I fixed by doing

pip3 install pandas

Instead of

pip install pandas
Answered By: Ramen Noodles

I had this problem as well and tried a few different things until I realized my python path under settings.json (python.pythonPath) was incorrect and pointing to the wrong directory. The path should be to where the Python.exe file is under programs.

Answered By: wolfblitza

For python 3.7, type following in CMD:

CD C:Users[path]Continuumanaconda3Libsite-packages


pip3 install pandas
Answered By: Satyajeet Patil

In my case, I installed panda instead of pandas. My installation was missing the last letter s.

Answered By: TryCatchFinally

My problem was running pandas from an ipython shell. The error message from the original post kept cropping up, despite having pandas installed. Then I started reading messages (see below). Installing ipython in the virtual environment didn’t help, BUT deactivating the virtual environment and activating it again did.

➜ ipython
/.../python3.10/site-packages/IPython/core/ UserWarning: 
Attempting to work in a virtualenv. If you encounter problems, please install 
IPython inside the virtualenv.
Answered By: Roman Luštrik
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.