ImportError: cannot open shared object file: No such file or directory


I am trying to run an Arducam MT9J001 camera on a raspberry pi 3b+. I am getting the following error when I try to run the program, "ImportError: libcblas.so3: cannot open shared object file: No such file or directory." I have the computer vision software downloaded onto the raspberry pi, though it seems that it is still not working. I’m not sure what other information is viable to this project, but if there is something else I should be specifying please let me know.

Asked By: isaiahoptics22



What worked for me (I was missing some dependencies):

pip3 install opencv-python 
sudo apt-get install libcblas-dev
sudo apt-get install libhdf5-dev
sudo apt-get install libhdf5-serial-dev
sudo apt-get install libatlas-base-dev
sudo apt-get install libjasper-dev 
sudo apt-get install libqtgui4 
sudo apt-get install libqt4-test
Answered By: thvs86

Exact same solution as @thvs86 but here’s a single 1 line copy-paste so you don’t have to insert each command individually:

pip3 install opencv-contrib-python; sudo apt-get install -y libatlas-base-dev libhdf5-dev libhdf5-serial-dev libatlas-base-dev libjasper-dev libqtgui4 libqt4-test

Answered By: Human

You need to install only one package with neccessary shared object for it to work

sudo apt-get install libatlas-base-dev
Answered By: lucidyan