How to include package data with setuptools/distutils?


When using setuptools, I can not get the installer to pull in any package_data files. Everything I’ve read says that the following is the correct way to do it. Can someone please advise?

      'myapp': ['data/*.txt'],

where myapp/data/ is the location of the data files.

Asked By: cmcginty



Update: This answer is old and the information is no longer valid. All configs should use import setuptools. I’ve added a more complete answer at

I solved this by switching to distutils. Looks like distribute is deprecated and/or broken.

from distutils.core import setup

      'myapp': ['data/*.txt'],
Answered By: cmcginty

Moving the folder containing the package data into to module folder solved the problem for me.

See this question: ignored on "python install" – no data files installed?

Answered By: exhuma

I just had this same issue. The solution, was simply to remove include_package_data=True.

After reading here, I realized that include_package_data aims to include files from version control, as opposed to merely “include package data” as the name implies. From the docs:

The data files [of include_package_data] must be under CVS or Subversion control

If you want finer-grained control over what files are included (for example, if
you have documentation files in your package directories and want to exclude
them from installation), then you can also use the package_data keyword.

Taking that argument out fixed it, which is coincidentally why it also worked when you switched to distutils, since it doesn’t take that argument.

Answered By: Joe

I realize that this is an old question, but for people finding their way here via Google: package_data is a low-down, dirty lie. It is only used when building binary packages (python bdist ...) but not when building source packages (python sdist ...). This is, of course, ridiculous — one would expect that building a source distribution would result in a collection of files that could be sent to someone else to built the binary distribution.

In any case, using will work both for binary and for source distributions.

Answered By: larsks

Following @Joe ‘s recommendation to remove the include_package_data=True line also worked for me.

To elaborate a bit more, I have no file. I use Git and not CVS.

Repository takes this kind of shape:

    - .git/
    - myproject
        - some_mod
        - config
            - other_settings.special
            - cool.huh
            - other_settings.xml
        - words

from setuptools import setup, find_packages
import os.path

setup (
    version = "4.19",
    packages = find_packages(),  
    # package_dir={'mypkg': 'src/mypkg'},  # didnt use this.
    package_data = {
        # If any package contains *.txt or *.rst files, include them:
        '': ['*.txt', '*.xml', '*.special', '*.huh'],

    # Oddly enough, include_package_data=True prevented package_data from working.
    # include_package_data=True, # Commented out.
#               ('bitmaps', ['bm/b1.gif', 'bm/b2.gif']),
        ('/opt/local/myproject/etc', ['myproject/config/', 'myproject/config/other_settings.special']),
        ('/opt/local/myproject/etc', [os.path.join('myproject/config', 'cool.huh')]),
        ('/opt/local/myproject/etc', [os.path.join('myproject/config', 'other_settings.xml')]),
        ('/opt/local/myproject/data', [os.path.join('myproject/words', 'word_set.txt')]),

    install_requires=[ 'jsonschema',
        'logging', ],

     entry_points = {
        'console_scripts': [
            # Blah...
        ], },

I run python sdist for a source distrib (haven’t tried binary).

And when inside of a brand new virtual environment, I have a myproject-4.19.tar.gz, file,
and I use

(venv) pip install ~/myproject-4.19.tar.gz

And other than everything getting installed to my virtual environment’s site-packages, those special data files get installed to /opt/local/myproject/data and /opt/local/myproject/etc.

Answered By: HeyWatchThis

include_package_data=True worked for me.

If you use git, remember to include setuptools-git in install_requires. Far less boring than having a Manifest or including all path in package_data ( in my case it’s a django app with all kind of statics )

( pasted the comment I made, as k3-rnc mentioned it’s actually helpful as is )

Answered By: vincent

Ancient question and yet… package management of python really leaves a lot to be desired. So I had the use case of installing using pip locally to a specified directory and was surprised both package_data and data_files paths did not work out. I was not keen on adding yet another file to the repo so I ended up leveraging data_files and option –install-data; something like this

pip install . --install-option="--install-data=$PWD/package" -t package  
Answered By: Mat Baker

I had the same problem for a couple of days but even this thread wasn’t able to help me as everything was confusing. So I did my research and found the following solution:

Basically in this case, you should do:

from setuptools import setup

   package_dir={'myapp':'myapp'}, # the one line where all the magic happens
      'myapp': ['data/*.txt'],

The full other stackoverflow answer here

Answered By: moctarjallo

Using setup.cfg (setuptools ≥ 30.3.0)

Starting with setuptools 30.3.0 (released 2016-12-08), you can keep your very small and move the configuration to a setup.cfg file. With this approach, you could put your package data in an [options.package_data] section:

* = *.txt, *.rst
hello = *.msg

In this case, your can be as short as:

from setuptools import setup

For more information, see configuring setup using setup.cfg files.

There is some talk of deprecating setup.cfg in favour of pyproject.toml as proposed in PEP 518, but this is still provisional as of 2020-02-21.

Answered By: gerrit

Just remove the line:


from your setup script, and it will work fine. (Tested just now with latest setuptools.)

Answered By: Ian

I found this post while stuck on the same problem.

My experience contradicts the experiences in the other answers.
include_package_data=True does include the data in the
The explanation in the setuptools
lacks context and troubleshooting tips, but
include_package_data works as advertised.

My setup:

  • Windows / Cygwin
  • git version 2.21.0
  • Python 3.8.1 Windows distribution
  • setuptools v47.3.1
  • check-manifest v0.42

Here is my how-to guide.

How-to include package data

Here is the file structure for a project I published on PyPI.
(It installs the application in

├── my_package
│   ├──
│   ├──
│   └── _my_data          <---- folder with data
│       ├── consola.ttf   <---- data file
│       └── icon.png      <---- data file

Starting point

Here is a generic starting point for the setuptools.setup() in


setuptools.find_packages() includes all of my packages in the
distribution. My only package is my_package.

The sub-folder with my data, _my_data, is not considered a
package by Python because it does not contain an,
and so find_packages() does not find it.

A solution often-cited, but incorrect, is to put an empty file in the _my_data folder.

This does make it a package, so it does include the folder
_my_data in the distribution. But the data files inside
_my_data are not included.

So making _my_data into a package does not help.

The solution is:

  • the sdist already contains the data files
  • add include_package_data=True to include the data files in the bdist as well

Experiment (how to test the solution)

There are three steps to make this a repeatable experiment:

$ rm -fr build/ dist/ my_package.egg-info/
$ check-manifest
$ python sdist bdist_wheel

I will break these down step-by-step:

  1. Clean out the old build:
$ rm -fr build/ dist/ my_package.egg-info/
  1. Run check-manifest to be sure matches the
    Git index of files under version control:
$ check-manifest

If does not exist yet, create it from the Git
index of files under version control:

$ check-manifest --create

Here is the that is created:

include *.md
recursive-include my_package *.png
recursive-include my_package *.ttf

There is no reason to manually edit this file.

As long as everything that should be under version control is
under version control (i.e., is part of the Git index),
check-manifest --create does the right thing.

Note: files are not part of the Git index if they are either:

  • ignored in a .gitignore
  • excluded in a .git/info/exclude
  • or simply new files that have not been added to the index yet

And if any files are under version control that should not be
under version control, check-manifest issues a warning and
specifies which files it recommends removing from the Git index.

  1. Build:
$ python sdist bdist_wheel

Now inspect the sdist (source distribution) and bdist_wheel
(build distribution) to see if they include the data files.

Look at the contents of the sdist (only the relevant lines are
shown below):

$ tar --list -f dist/my_package-0.0.1a6.tar.gz
my_package-0.0.1a6/my_package/_my_data/consola.ttf <-- yay!
my_package-0.0.1a6/my_package/_my_data/icon.png    <-- yay!

So the sdist already includes the data files because they are
listed in There is nothing extra to do to include
the data files in the sdist.

Look at the contents of the bdist (it is a .zip file, parsed
with zipfile.ZipFile):

$ python

Note: you need to create your own script to produce the
above output. It is just three lines:

from zipfile import ZipFile
path = "dist/my_package-0.0.1a6-py3-none-any.whl" # <-- CHANGE

As expected, the bdist is missing the data files.

The _my_data folder is completely missing.

What if I create a _my_data/ I repeat the
experiment and I find the data files are still not there! The
_my_data/ folder is included but it does not contain the data


Contrary to the experience of others, this does work:

    include_package_data=True, # <-- adds data files to bdist

With the fix in place, redo the experiment:

$ rm -fr build/ dist/ my_package.egg-info/
$ check-manifest
$ python.exe sdist bdist_wheel

Make sure the sdist still has the data files:

$ tar --list -f dist/my_package-0.0.1a6.tar.gz
my_package-0.0.1a6/my_package/_my_data/consola.ttf <-- yay!
my_package-0.0.1a6/my_package/_my_data/icon.png    <-- yay!

Look at the contents of the bdist:

$ python
my_package/_my_data/consola.ttf        <--- yay!
my_package/_my_data/icon.png           <--- yay!

How not to test if data files are included

I recommend troubleshooting/testing using the approach outlined
above to inspect the sdist and bdist.

pip install in editable mode is not a valid test

Note: pip install -e . does not show if data files are
included in the bdist.

The symbolic link causes the installation to behave as if the
data files are included (because they already exist locally on
the developer’s computer).

After pip install my_package, the data files are in the
virtual environment’s lib/site-packages/my_package/ folder,
using the exact same file structure shown above in the list of
the whl contents.

Publishing to TestPyPI is a slow way to test

Publishing to TestPyPI and then installing and looking in
lib/site-packages/my_packages is a valid test, but it is too

Answered By: Mike Gazes

For a directory structure like:

├── foo
│   ├──
│   ├──
│   └── data.txt


#!/usr/bin/env python
# -*- coding: utf-8 -*-

from setuptools import setup

NAME = 'foo'
DESCRIPTION = 'Test library to check how setuptools works'
URL = ''
EMAIL = '[email protected]'

        'Programming Language :: Python',
        'Programming Language :: Python :: 3',
        'Programming Language :: Python :: 3.6',
    package_data={'foo': ['data.txt']},

python bdist_wheel works.

Answered By: ksha

Like others in this thread, I’m more than a little surprised at the combination of longevity and still a lack of clarity, BUT the best answer for me was using check-manifest as recommended in the answer from @mike-gazes

So, using just a setup.cfg and no and additional text and python files required in the package, what worked for me was keeping this in setup.cfg:

packages = find:
include_package_data = true

and updating the based on the check-manifest output:

include *.in
include *.txt
include *.yml
include LICENSE
include tox.ini
recursive-include mypkg *.py
recursive-include mypkg *.txt
Answered By: Stephen Arnold

Starting with Setuptools 62.3.0, you can now use recursive wildcards ("**") to include a (sub)directory recursively. This way you can include whole folders with all their folders and files in it.

For example, when using a pyproject.toml file, this is how you include two folders recursively:

"" = ["**"]
"ema_workbench.examples.models" = ["**"]

But you can also only include certain file-types, in a folder and all subfolders. If you want to include all markdown (.md) files for example:

"" = ["**/*.md"]

It should also work when using or setup.cfg.

See for the details.

Answered By: Ewout ter Hoeven
Categories: questions Tags: , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.