M1 Mac – PyCharm – Unable to run on arm64


It appears I’m unable to run the arm64 architecture in PyCharm and I don’t understand why. I would really like to learn what I’m doing wrong.

I’m on a 2021 M1 MacBook Pro with macOs Monterey 12.6.2

PyCharm 2022.3.2 (Community Edition)
Runtime version: 17.0.5+1-b653.25 aarch64

For my virtual environments I use conda (miniforge3) version 4.14.0

When I run ‘uname -m’ in the PyCharm terminal it returns ‘x86_64’, however when I run the same command in zsh terminal I get ‘arm64’. Both are executed in the conda ‘base’ environment and I would have expected the architectures to be the same.

What I’ve done

Thanks in advance for your help!

Asked By: Daalen



The issue is solved by deleting the current version of PyCharm and removing the left over ID directories as explained here https://www.jetbrains.com/help/pycharm/directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html#logs-directory

After re-installing PyCharm it now works!

Answered By: Daalen
Categories: questions Tags: , , ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.