Read a file on App Engine with Python?


Is it possible to open a file on GAE just to read its contents and get the last modified tag?

I get a IOError: [Errno 13] file not accessible:
I know that i cannot delete or update but i believe reading should be possible
Has anyone faced a similar problem?

Asked By: PanosJee



You can read files, but they’re on Goooogle’s wacky GAE filesystem so you have to use a relative path. I just whipped up a quick app with a file and test.txt in the same folder. Don’t forget the ‘e’ on st_mtime.

import os
from google.appengine.ext import webapp
from google.appengine.ext.webapp import util

class MainHandler(webapp.RequestHandler):

  def get(self):
    path = os.path.join(os.path.split(__file__)[0], 'test.txt')


def main():
  application = webapp.WSGIApplication([('/', MainHandler)],

if __name__ == '__main__':
Answered By: MStodd

You’ve probably declared the file as static in app.yaml. Static files are not available to your application; if you need to serve them both as static files and read them as application files, you’ll need to include 2 copies in your project (ideally using symlinks, so you don’t actually have to maintain an actual copy.)

Update Nov 2014:

As suggested in the comments, you can now do this with the application_readable flag:


Optional. By default, files declared in static file handlers are
uploaded as static data and are only served to end users, they cannot
be read by an application. If this field is set to true, the files are
also uploaded as code data so your application can read them. Both
uploads are charged against your code and static data storage resource


Answered By: Wooble

+1 for the new “application_readable: true” feature. Before using this new feature I did run into an issue with GAEs’ “wacky” file system while getting the NLP Montylingua to import.

Issue: Monty uses the open(filename,’rb’) and a file pointer to in bytes from the static files. My implementation worked on my local windows system but failed upon deployment!

The fix: Specify the expected bytes to read #4 binary bytes

Appears to be something related to the 64 bit GAE server wanting to read in more (8 by default) bytes. Anyways, took a while to find that issue. Montylingua loads now.

Answered By: jonincanada

I came up strange but working solution 🙂 Jinja 🙂

Serving static files directly sometimes become a headache with GAE. Possible trade-off from performance let you move straigh forward with Jinja

- url: /posts/(.*.(md|mdown|markdown)) 
  mime_type: text/plain
  static_files: static/posts/1
  upload: posts/(.*.(md|mdown|markdown))

from jinja2 import Environment
from jinja2.loaders import FileSystemLoader
posts = Environment(loader=FileSystemLoader('static/posts/')) # Note that we use static_files folder defined in app.yaml
post = posts.get_template('2013-11-13.markdown')

import markdown2 # Does not need of course

class Main(webapp2.RequestHandler):

    def get ( self ):
        self.response.headers[ 'Content-Type' ] = 'text/html'

        self.response.write ( markdown2.markdown( post.render()) )  # Jinja + Markdown Render function

Did you get it 😉 I tested and It worked.

Answered By: guneysus

With webapp2, supposing you have pages/index.html at the same path as

#!/usr/bin/env python

import webapp2, os

class MainHandler(webapp2.RequestHandler):
    def get(self):
        path = os.path.join(os.path.split(__file__)[0], 'pages/index.html')
        with open(path, 'r') as f:
            page_content =

app = webapp2.WSGIApplication([
    ('/', MainHandler)
], debug=True)
Answered By: Ivan Chaer

I can’t see an answer for when the file hasn’t been marked as static, and you’re trying to read it in mode 'rt'; apparently that doesn’t work. You can however open files just fine in mode 'rb', or just plain 'r'. (I wasted about 10 minutes on that ‘t’.)

Answered By: Fredderic U
Categories: questions Tags: ,
Answers are sorted by their score. The answer accepted by the question owner as the best is marked with
at the top-right corner.