Why can I not create a wheel in python?


Here are the commands I am running:

$ python setup.py bdist_wheel
usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: setup.py --help [cmd1 cmd2 ...]
   or: setup.py --help-commands
   or: setup.py cmd --help

error: invalid command 'bdist_wheel'

$ pip --version
pip 1.5.6 from /usr/local/lib/python3.4/site-packages (python 3.4)

$ python -c "import setuptools; print(setuptools.__version__)"

$ python --version
Python 3.4.1

$ which python

Also, I am running a mac with homebrewed python

Here is my setup.py script:

I’m going absolutely crazy — I can’t figure out why this wouldn’t be working.

Asked By: vitiral



Install the wheel package first:

pip install wheel

The documentation isn’t overly clear on this, but “the wheel project provides a bdist_wheel command for setuptools” actually means “the wheel package…”.

Answered By: Thomas Orozco

I also ran into the error message invalid command 'bdist_wheel'

It turns out the package setup.py used distutils rather than setuptools.
Changing it as follows enabled me to build the wheel.

#from distutils.core import setup
from setuptools import setup
Answered By: geographika

Update your setuptools, too.

pip install setuptools --upgrade

If that fails too, you could try with additional --force flag.

Answered By: luckydonald

I also ran into this all of a sudden, after it had previously worked, and it was because I was inside a virtualenv, and wheel wasn’t installed in the virtualenv.

Answered By: jbg

I tried everything said here without any luck, but found a workaround.
After running this command (and failing) : bazel-bin/tensorflow/tools/pip_package/build_pip_package /tmp/tensorflow_pkg

Go to the temporary directory the tool made (given in the output of the last command), then execute python setup.py bdist_wheel. The .whl file is in the dist folder.

Answered By: Aigrefin

Throwing in another answer: Try checking your PYTHONPATH.

First, try to install wheel again:

pip install wheel

This should tell you where wheel is installed, eg:

Requirement already satisfied: wheel in /usr/local/lib/python3.5/dist-packages

Then add the location of wheel to your PYTHONPATH:

export PYTHONPATH=$PYTHONPATH:/usr/local/lib/python3.5/dist-packages/wheel

Now building a wheel should work fine.

python setup.py bdist_wheel
Answered By: theo-brown

It could also be that you have a python3 system only.
You therefore have installed the necessary packages via pip3 install , like pip3 install wheel.

You’ll need to build your stuff using python3 specifically.

python3 setup.py sdist
python3 setup.py bdist_wheel


Answered By: Bart Dorlandt

Update your pip first:

pip install --upgrade pip

for Python 3:

pip3 install --upgrade pip
Answered By: Tombart